Root motion moves in opposite direction of intended

Hi all,

So, I have a creature (non-bipedal, but with a Character parent; this is kind of a follow-up to [this question][1]), and I want it to walk forward.

The problem is that when I turn on root motion, the creature moves backwards instead of forward. Before turning on root motion, the creature does the expected movement, “snapping” back to its original position each time. After turning on root motion (using Ref Pose as Root Motion Root Lock), the creature moves in the same direction, only backwards.

No root motion


Root Motion Root Lock = Ref Pose


When I select “Show Reference Pose”, the reference pose is facing the wrong direction (same as in the second picture above). I tried rotating the skeleton’s root bone 180° in the skeleton tab, which made the animation look correct in the animation tab, but the reference pose and Graph tab still showed up backwards.

I have tried switching “Root Motion Root Lock” to Anim First Frame, but for whatever reason, an Idle animation (which I plan on using in a blend space once this is figured out) is far below the proper placement at this setting.

Idle Animation [Pic1: Ref Pose] [Pic2: First Frame]



I can only imagine this has something to do with me having import settings trouble or something wrong with my model (I’m using Blender), but it’s hard to say. Any thoughts?

After trying to import the model several different times, changing the fbx forward direction, maybe doing some other things with rotation and scale (I’m honestly not quite sure what I’ve done…), the problem still remains. Is there a way to change the reference pose? Or, why would the “first frame” option move the creature down so much?

It sounds like you’ll need to reimport the skeletal mesh with proper facing direction and update the reference pose when doing so.

I’m not sure if I should be marking this question as correct or not, as I am still very confused as to why everything was happening the way it was. Regardless, using the Ref Pose button, I was able to turn the dinosaur’s root bone 180º, which completely fixed the walking backwards problem. I didn’t need to reimport.

Has the Ref Pose button always been there, or was it added sometime after 4.7? I feel like I would’ve noticed that.

Okay, I lied. Everything is not fixed. Though editing the ref pose in the Blend Space makes everything look good in the Animation Editor, in the Animation Blueprint Graph preview and when I play the actual game, the mesh is still backwards.

I had this root bone fight a couple months ago. The fix ended up being that the root bone can’t be grouped in any sort of hierarchy in the 3d package. The bones must exist only the the main scene with no grouping whatsoever. Let me know if that helps!

Hi, have you got your problem solved? I have this too, can you please answer this question again if you have any solution ? thanks a lot!