Download

Root motion for non-default mesh

Hey guys!

On my character, I’ve deleted the default Mesh object.
And now when I play root animations on another mesh component, it doesn’t work!

Any ideas? :smiley:

Is the anim BP the same? Did you re enable root motion?

It’s the same animBP, so I wouldnt need to re-enable it, right? Or is there a place to enable root motion for meshes components?

You are right. If its the same animation graph then it should still be enabled.
If you didn’t change animations or anim graphs then its a bit hard to know where to look… maybe post some more information.

Just double check your anim graph didn’t go haywire that use root motion is still on. And that your animations are set to root motion

I’ve the same problem… :frowning:

Root motion is tied to the root bone of the skeleton in the animation and is not related to the mesh component, so if you are changing mesh components on the same skeleton the root motion should function the same. I’d suggest making sure you have the correct player/skeleton selected in the Game mode under World settings. If this is correct, make sure root motion is selected in the Anim Sequence and, if you are using a Montage, make sure “root motion from everything” is selected.

Hello,
>should function the same : but not in fact…
Everything else is correct : it was functionning well before UE4 crash my BP Character Mesh.
The only difference is that my BP Character has a “Blank” Mesh i can’t delete or modify - it’s “NONE” (in matrix infos) and details is blank

I’m posting the following image for clarification (to make sure we are referring to the same Blueprint and Mesh):

Blueprints.png

So, if I understand you correctly, after UE4 Crashed, your Character Blueprint has a blank reference to a Skeletal Mesh and you can no longer select a replacement Skeletal Mesh. If that is the case I would first, create a new Character Blueprint and try selecting a Skeletal Mesh. If that works, you can copy and paste your Nodes from your previous Blueprint to prevent having to start from scratch.

If that does not work, your Skeletal Mesh may have been corrupted when UE4 crashed. If this is the case, delete the Skeletal Mesh and reimport it. If you are using UE4 assets, you’ll have to open a new project and then migrate them to your current project.

Let me know if this resolves the issue or if I’m not understanding the problem you are experiencing.

*Also make sure the Skeletal Mesh you are using/replacing is set up with the same Skeleton that the desired animations with the root motion are referencing.

It’s a character BP - it’s the child of a class which is a child of character.h:
ac38b7e0e5336ead6476073f5d122ea8f22a66ba.png
My skeletal mesh is not corrupted because it functions with other BP Character. If i delete it (i’ve tried first), there is no modification for my character BP, because the reference to this skelmesh seems to be broken. Migration to last version of UE4 has the same result too (UE4.8.2) - The original version (with crash) is 4.7.6.
Oh It’s a huge work: there is more than 3 month of work behind this character… there is thousands of nodes, hundreds of variables
and most of nodes don’t copy correctly (they reference the old BP Char)… I’ve tested this way, but it’s too difficult…
Is there an automatic way to copy elements and change references ?

Hi benicourt,

Thanks for the clarification. Unfortunately there is not a way to automatically copy elements and change references and it appears your Character Blueprint file is corrupted beyond repair. You will likely have to recreate it using your old file as a reference. However, if you’d like to see if we can fix it, you can send me your original 4.7.6 project via PM and we’ll do the best we can.

Hi Steve,
Thanks a lot for your proposition. We’re still in rush to a presentation soon, but i’ll come back you after this rush. Thanks again.