Root motion cannot handle rotations

Hi.

I picked up that root motion is somewhat problematic.
My root motion is on a Y-Axis. And i have rotations happening.

It seems it extracts the incorrect axis and starts going strange things.
4.7.3

In 4.6 it was working fine.
Please see the difference.

https://www.youtube.com/watch?v=N0kGEoz7QWw&feature=youtu.be

Hey Crocopede,

Can I get a breakdown of how your character movement and animations are set up? Either a series of screenshots or even another screencap video would be great. I’ll admit that I don’t have a ton of experience with root motion, but I’d like to get as much info as possible before talking to one of our engineers.

-Matt W.

Hi Matt.

I will do you one better and supply a demo project containing all the relevant files. Can i PM you the download link on your forums account? I saw your username there is Matt.Williams

If its a noob error on my behalf that would be awesome… but i noticed stuff like Extract rotation data is no longer available and i read its now always on. So i might be jumping to conclusions here but hopefully we can get to the bottom of this.

Yep, that’s me. It’s sometimes better to just put my eyes on it anyways. So fire away.

-Matt W.

Excellent thank you.
Its busy uploading. You should get the link in the next 30 minutes.

I tried making things less irksome so i created a folder called “FilesofInterest”. This contains all the relevant files (animations,Blueprints etc)

I also created 2 character blueprints. One called MyCharacterNoRoot and one called MyCharacterWithRoot. Under world settings you can switch between the two by selecting the one you wish to test.

NoRoot is exactly that. It contains no root animations and should demonstrate what it should look like. The other one contains the issue.

Keys
A = left, D=Right, X=DiveRoll or crouch, Shift = Run
You need to be above a certain speed to diveroll. But it only takes a brisk walk to achieve it.

Ok so the other thing i did was i separated the logic in the blueprints and highlighted them green in comment boxes so you can immediately see which section is relevant.

If i missed something i apologize.

Linking the forum and answerhub issues.

Hi.

Just wanted to follow up and find out if you were able to confirm if this is a bug.

Thx

I’m having exactly the same problem. I’ve tried animating my character in crazy spin axis just to check if it would ever spin in the right direction, but it never does. It’s insane LOL
Does anyone have a fix for this? I followed up on that link and that blueprint workaround is just too complex for me as a beginner.

i think i have a fix.
Seems that proper root extraction requires a bone at 0,0,0

At least this is what i read on the animation softwares help files… will test just now. coffee first

Still busy reworking all my animations. After adding an additional bone to the rig i sort of lost all my animations. So just getting the basic ones done. Roughly 15 animations.

Might take a day or two actually :confused:

So, on every animation I need to have the root bone at 0,0,0? I guess I’ll have to remake my animations as well… Well, let’s get to it I guess xD

The initial rig needs to have it from what i read.
Beginner mistake i guess.

Im almost at a point where i cant test though.

Hi Matt.
Im happy to report that the root motion issue was not a bug but in fact my noobness.
My rig did not contain a root bone, and i was using my hips as the root to drive the animation. This created some bad results.

I redid my rig and all my animations and everything is working correctly now.
Apologies for wasting your time.

Would it be possible to add a note in https://docs.unrealengine.com/latest/INT/Engine/Animation/RootMotion/index.html

that specifies you do need a root bone at 0,0,0
I honestly was a not aware that this is a requirement… and im sure there are other people who also just started digging into animations and might experience the same thing.

Thanks again.
Cheers

Hey Crocopede,

I’m glad you found the issue and you weren’t, by any means, wasting my time. Sorry for not responding very frequently the past few days.

As far as a note in the documentation, there is a red box in the “What is Root Motion” section that states that the root bone needs to be at the origin. However, it then goes on to say in parenthesis “On the Floor”, which is not the full meaning of the “origin”. It could say “0, 0, 0 with no rotation”. I’ll submit this to our docs team.

Thanks,

Matt W.

EDIT: I’ve entered UEDOC-1460 with this request.