Root bone issue with animations - floating character (Includes animated example)

I’ve struck an issue with my animations. The following gif is meant to be a landing animation, and instead of moving the way it did when I animated it in maya, his legs go up to meet his root bone, unlike how when he hits the ground and goes into a crouch position. I’m having a similar issue with our idle animation, where his breathing is causing his pelvis to remain motionless, but his feet to slightly rise and fall above ground level. Is this something others have encountered before? Is it easy to fix? Or have I animated wrong in maya?

Could you take a video with “show bone” enabled? Or you can just select root and take a video. By default, it should show the gizmo on the location of the bone.



Sure, as soon as I get home I’ll attach a vid!

EDIT: Alrighty, here we are. I’ll mention that I have Enable Root Motion selected, and also that I’ve had to rotate and move him so he was right way up. He was facing upwards when I imported him:

I am not sure if this would help, but Zak put this up. Just the re-targeting section, just in case. Sorry if this is a double up or it is what you have already done. Around 3:00 mins

With root motion you need to kind of treat the root bone as the floor. So, it moves with the pelvis on X and Y but not on Z. So when the character crouch, the root bone stay on the floor, while the pelvis moves down.

I don’t think I need to retarget because the animation was made with that character’s skeleton anyway. Ahh crud. In regards to what Obihb said then, it sounds like I may not be able to use this skeleton as I used the root bone as part of the animation. Is that correct? It’s not a huge deal as this was only a placeholder, I guess, but still. =/

If you’re doing custom animation, it’s easy to fix. You can just either negate the Z movement, or set up a quick rig that eliminates that movement regardless of being keyed.

If you’re using Max and you have any trouble with it, I can help you out. I guess even if not using Max, I can fix it on the FBX import. Don’t know if you’re using a custom rig for animation or what the deal is, but either way, I can help you out there if you need it.