Root bone is scaled by x100

Hello, so this issue is pretty weird. Let me get into what exactly occurs.

When Importing an FBX file from Blender into Unreal Engine the root bone of the armature is scaled by x100. Even though the scale of the object matches up with the dimensions in blender as in the object isn’t scaled up by x100.

The issue becomes apparent when a object is attached to a bone. When adding a preview asset to a bone I realized that it becomes x100 bigger. I could just use a socket and go along with my day but I am afraid this will cause issues in the future. Does anybody have any recommendations on how I could fix this issue? I will provide all of my export settings below.

Any help is appreciated I thank you for taking your time to read this.

alt text

1 Like

If you need the UE4 import settings I couldn’t provide it above due to only being limited to 5 images so here it is.

For anyone else who is looking for a solution, I ended up purchasing the Better FBX export tool link :

It worked just fine and greatly. Otherwise the answer maybe to scale the mesh up by 100x then scaling down the armature by .01 may also fix this issue.

So this was a solution that worked for you? I can’t figure out why Im getting the same 100 scaling on the bones either

Hey, still the same problem here using 4.27.0, on a blank project. The artist did the exact same thing (same import parameters, same fbx, same blank project) on 4.27.2 and he has no problem, the root bone scale is 1/1/1 when mine is 100/100/100.

I’ll try with 4.27.2, just after downloding it.

I got this issue 4.27.2 but my issue came from scaling as @Nino_Mancuso mentioned.

The issue: when moving collisions and such in the viewport things were moving away from the pivot point with a multiplier.

The cause: wrong bone scaling

The solution: Have the mesh be 1:1 scale and the bones be 1:001 scaled when exporting. Hope this helps someone!

The best solution I’ve found is using plugins such as better FBX export. It tends to happen due to blender export stuff a quick way to fix this could be setting the dimensions of blender to meters but applying the meter scale as .01 to match centimeters. Hope this helps!

I was struggling with the same problem, but after looking into it I was able to solve it without any external plugins. I created a video with all the details, including how to solve the root joint scale. I hope that it will be a useful resource to anyone else running into the same problem.

[Blender to Unreal Engine 5] Correct FBX Export Settings for Characters: [Blender to Unreal Engine 5] Correct FBX Export Settings for Characters - YouTube


legit. Solved issue

This is, by far, the best answer. Having a plugin do it right is nice, but understanding the problem and how to fix it is very important. And this video gets the job done well.
Thank you, Daniel!

I made a tool to fix this in UE editor. But it doesn’t fix physics asset.

In 2023 I still had this issue where the rig was the correct scale but displaying the bones ended with a cluttered viewport since the world space size was 100 for the bones. I followed your suggestion and purchased the same Better FBX Export tool and it resulted in fixing the bone scale. Im not sure what the issue is exactly but it would be nice if blender could sort their export and scaling issues with other software.