Download

Room walls collisions

Hi guys,
I’m very new with Unreal, and I only began to study Unity a month ago. There, I used planes for collisions, so objects without thickness. In Unreal I’m trying to export a wall with windows and an object UCX_WindowWall to represent the collision object but Unreal always wraps it for me. This object is actually 3 walls connected in wide angle, so I guess it’s concave. Like half of a hexagon.

I also tried creating 3 boxes instead of planes, but then unreal wrapped those too when they were imported.

In MAX I usually have walls of a house as one object, not every wall a single box, so I’ll import the walls as one object, and I will need collisions on all those sides, not wrapped as a single object. Make any sense?

I know there’s a simple solution but I can’t find it.

Hi, open the mesh editor, in the top you should find collision drop down menu. Select auto convex collision and set Max hulls and Max hulls verts to max and apply.

If that doesn’t fix your problem simply remove the collision of the mesh and instead place blocking volumes at the position of the walls.

The first method creates a really ugly solution - like in the screen capture. I made nice 3 flat surfaces for this object, so there is no way to use them?
Is there a way to recall that UCX object? After I did auto convex it replaced it and now I don’t know where it is…I know I can reimport but I want to learn all the options.

Untitled-1.jpg

I tried this again like some guy in a tutorial did it. I created three boxes and attached them, so it’s not one concave object. When I import, Unreal closes them for me.
Any ideas? The guy in the tutorial also merged all his boxes, and when he imported he had them all.

1dbc963bdba43dfee5dd151916ae7ae632887e5b.jpeg

5401e3208dce08ec115ee992bfb2d0bcf758c6d8.jpeg

Take a look at this video and choose one way: https://www.youtube.com/watch?v=TTsAYpqHU-c :slight_smile:

For your upper problem → make sure to disable “use one convex hull…” + “auto generate collision” in your import settings

Totally skipped that part. Now the collision mesh looks as endless huge weird mesh, still something wrong, will have to play some more with it.
Thank you!

Have you tried like I suggested to place 3 blocking volumes with the same shape as the walls?

That mostly happens when you just copy and paste your mesh + rename it to UCX_… → you will have to create basics shapes :slight_smile:

I did several tests starting from basics, and at the end I just rebuild the walls object as well as it’s UCX component. This is an older scene (like from 2006 lol) and I probably modeled these walls in some weird way that screwed everything up. Now it’s working perfectly!

On the other note, I do plenty of rendering on my system, often my RAM is filled with 15GB of data, and I can use my computer normally, but when Unreal computes lighting it halts everything. Anyone else experiencing this? My engine is up to date.

So my scene is slowly coming together, and right now I’m going through lights in GI. If I have a default sky system, do I need to create a directional light and link it to it? When I do I loose some control over rotation, so I’m not sure if I create and link the light, where do I then change the “north” of the sky, and time of day, or that other sun angle?

Also, I added a Skylight, was that necessary? I feel as if I’m not getting enough light into my scene. Contrast is too high and shadows too hard. On the second image, it looks as if there is no light entering the room, though it should since I have a Skylight too.

Untitled-1.jpg

Untitled-2.jpg

Trying to ramp settings more, but still I would like to hear from you guys if this is the normal look or am I doing something wrong? The shadows are really strong and the light doesn’t seam to enter in certain areas. Should I just add more lights to those areas?

It’s normal. In world settings, lightmass settings add some more bounces to the indirect lighting and up the quality. You can also increase skylight’s power.

It looks as if you dont have a lightmass importance volume covering the building. Create one if you dont have it already and keep in mind that a directional light alone may not be enough to lit the entire interior, so you may need to use additional light sources and light&plane combination in front of the windows to get extra bounce.

Lightmass importance is in place and I will try more lights, and see what is this light&plane :slight_smile: I guess something like vray lights. They are usually rect planes that emit light.

What about rendering? I mean “build”. My computer basically halts after it starts. Like half a minute later. Mouse won’t move, can’t alt-tab etc.