Download

Rock materials from Bridge are all glossy

Hello! I’m new to UE and am excited to start learning UE5. I’ve tried adding several different rock prefab assets and materials from the Bridge (from the Nordic Beach and Canyons of Utah collections) into a new FPS template project but they all appear incredibly glossy, like wet plastic. I’ve been searching the forum, searching on YouTube and Google but can’t figure out what is wrong. Maybe it’s a bug? I’ve seen other people on YouTube use these assets where they look correct, with a matte real-to-life material.

Here’s what I see after making a new project, opening Bridge, adding a mesh asset Nordic Beach Rock Formation to the project and opening the imported mesh in the editor from the content drawer:

Grateful for any help! Thank you

Find the channel-packed texture (labeled ARD, ORD, AR, etc.).
Open it.
In the settings on the right, look for COMPRESSION.
Uncheck “Compress without Alpha”.
Change the “Compression Settings” dropdown to “Masks (no sRGB)”.

Problem solved :wink:

3 Likes

OMG THANK you @dnwalkup! You really saved my week.
(If you have a paypal or anything like that I’d be happy to say thank you that way too)

Do you know if there’s a way to make this the default for stuff from Quixel?

1 Like

I don’t know about making a template, but you can go ahead and import all your textures and then easily change them all at once using the property matrix

1 Like

No need internet stranger! These shortcuts to issues are why we have these forums, but I very much appreciate the offer :grinning:

I’m sure they’ll update bridge with the correct settings down the line (this wasn’t happening to me in UE4), so for now, I would go with @BIGTIMEMASTER’s approach and use the property matrix.

Post a link to what you’re working on when it’s finished!

I’m a bit confused by this default, wouldn’t the majority of people want them non-glossy by default or is it a bug?

“Non-glossy” is correct PBR, there’s just an issue with the way Bridge is sending the material to Unreal right now, I’m sure it’ll get fixed.