Rigify in Blender to UE4 physics assets

I have a model that I made with makehuman and added a basic human skeleton with rigify. In blender it works great and I have made some animations. When I export it into Unreal Engine 4, the animations play fine, but I noticed that there are A LOT of bones in the armature. When I try to configure the physics asset in UE4 to add some to the animations, it is like something from a horror movie. It makes me think that it is because of all the extra bones that rigify puts in. Is there a way to export only the armature layer with the basic bone structure to the fbx so that in UE4 it doesn’t have all of the other bones? Also if this is the wrong way of thinking on how to accomplish my goal, advice would be helpful. I want a rig in blender with ik features for animation, but in UE4 I want to be able to add some physics to it with out it turning into a pot of mashed potatoes. I have posted this on the blender forums as well.

Just a shot in the dark, but maybe you are selecting this option when export “add leaf bones”


Unckeck it.

Yes I have tried with and without that checked, and it’s still a mess when adding physics.

You could try exporting with Only Deform. If that doesn’t help it your best bet is a UE4tools rig.

Just delete the physics bodies and constraints you don’t want in the physics model in PhAT.

You can see here in the first image there are lots of bones with no physics bodies.

With regular pose and light simulation on arms and hands:

Simulating while playing walk animation:

https://www.youtube.com/watch?v=jiXwDxCZtOc this tutorial

Neongho, this did the trick. The script for rigify and the exporter modifier helped for sure. None of the other tutorials that I have watched mentioned that stuff. I appreciate it! I modified the physics asset slightly because it ignored the feet and forearms when adding the bodies, but I added my own and it works great. No more spaghetti man. Now I can get some work done!