Right-Click Drag Popup Menu

This is probably going to seem like an extremely petty thing to report but it’s been driving me up the wall for a while. UE4 seems to have a peculiar problem with right-click dragging (either rotating the viewport camera or dragging off in graphs). Namely, certain times when letting go of the drag, the right-click menu would appear, causing me to drop my selection and having to close it. I cannot figure out how to reliably replicate it, I only know that I’d grab with my RMB, drag off into some distance and release it, just to have the menu pop up. This happens ~20% of the time and is extremely annoying, especially when moving around the game viewport and having my minuscule size actor selection dropped and be replaced with the skybox because that’s what I released my mouse on top on. Would it be possible to add an option to disable right click selection? Just have the context menu appear for whatever is selected, don’t change the selection.

Thanks!

hello DamirH,

Thanks for the post. I have entered a feature request for disabling/enabling right mouse. The jira ticket number is UE-11721 for tracking.

If there is anything else I can do just let me know,

Thanks , it’s great to see some love for this one. Can you tell me if there have been any additional reports of frustration caused by the right-click menu popping up when it shouldn’t or is this just me?

This has been driving me INSANE. I am glad someone has made a post about it. Somewhat oddly, I have been using unreal for about 4 months now and am just now in the last day or two noticing it.

I realized I had recently switched mouses. I went back to the old mouse and I don’t get the problem anymore. My other mouse was…uh…too right click sensitive I guess. They are both laser mouses, identical in type. The mouse that works does not trigger a “right click” if it also receives movement. The other mouse triggers the “right click menu” even if movement is applied.

I’m glad I’m not the only one. Although I haven’t noticed it for weeks now. Now that I saw this thread again I’m sure it’ll happen first thing in the morning though.

This has been driving me insane also. I don’t think it was always like this… I haven’t changed anything about my mouse configuration and it’s been this way for at least a couple of months now. A toggle in settings somewhere would be great. I will try some difference mice.

Hi all.

This ticket was closed long ago as “Won’t Fix” because we’d rather focus on fixing individual cases where the context menu appears inappropriately. If you can provide a reproduction case for this, please post it as a bug report on the UE4 Answerhub.

Thanks

FWIW, I changed my mouse and managed to fix this. I bought this one: https://www.amazon.com/gp/product/B00E290JRE

I looked for a mouse that could do a low DPI thinking that might be part of the problem. So if you are using a gaming mouse set to a high DPI (I had one set to 1000 before), try something like this set to 600dpi (it’s lowest setting). As far as I can tell, it seems to have fixed this intermittent but extremely annoying issue for me. I think “standard” mouse dpi is 800dpi.

This is happening to me constantly. UE is almost unuasable as a result.

This started happening to me as of 4.23.1, it is really annoying

This is a persistent issue, and always has been, for those that navigate the editor via holding alt + LMB (rotate cam) or alt + RMB (zoom cam). For those using RMB + WASD to navigate, this can still be an issue as the RMB menu does pop up upon release of RMB. For people who prefer to navigate via Maya controls, holding alt to rotate/zoom/pan, UE4 doesnt honor the ‘alt’ button as a ‘camera only’ designation - while holding alt, mesh can still be selected and RMB zoom periodically opens the right click menu when RMB is released. This has always been issue so I assume this is working as intended (unfortunately).

I’ve just open a ticket, and now i’ve discovered this topic…

So if i understand well, there is a really annoying problem, and no fix planned ?

Every time this has happened to me over the years it’s been a faulty mouse for what it’s worth.

i’m having the same problem but the solution i found out was that you have hold the right for a while and move with wasd key ,it work for me and those sudden pop up menu is not coming anymore

I too have been getting this issue, and after looking into it, in my case its caused by my mouse occasionally performing a second click after releasing the button. I was able to determine this using this event logger. I would suggest removing the events mouse over, out, enter, and leave for testing. What happens is when the button is released, the mouse up event fires, shortly followed by another mouse down and mouse up. UE4 is selecting objects because the second click occurs without the mouse moving.
I was able to fix it using X-mouse button control with its ‘ignore rapid clicks’ setting.

It happened to me too with a super Logitech mouse that I have.
I blamed Unreal first then I tested dragging on the desktop and observed context menu appearing while dragging.
So, I suggest to test how dragging behaves on desktop screen (or somewhere outside Unreal editor), maybe the mouse is the culprit (I know it is hard to believe it could be a mouse problem, especially when you have a good gaming mouse).