Rigging Tools (ART) Failing on "Build Control Rig"

I have tried to make a test rig using the default proxy mesh generated during the Rigging Tools Plugin Wizard, but it always hangs at 50% during the “Build Control Rig” step and fails right after taking the thumbnail image of the rig.

I have tried the plugin in both Maya 2013 and Maya 2014 with the same results. I have also tried removing Read-Only rights in the rigging tools folder, as well as creating a copy of the rigging tools folder on my C:\ drive and pointing the plugin to that. Also, grabbed the latest preview build and the rigging tools folder there with the same results.

It looks to be saving out a .mb file of the scene right before any control rig is built in the proper Projects folder:
D:\Unreal Engine\4.0\Engine\Extras\Maya_AnimationRiggingTools\MayaTools\General\ART\Projects\test\ExportFiles

It then looks to actually be building the control rig, but once the progress gets to 50% and hangs, I can see an error flash by in the help/message box and Maya loads a new empty scene.

The only error lines I could find in the script editor are:

Error: RuntimeError: file D:/UE4 Rigging Tools/MayaTools/General/Scripts\ART_autoRigger.py line 9265: setAttr: The attribute ‘driver_upperarm_l.rotateZ’ is locked or connected and cannot be modified.

Attached is the entire script editor log.
[link text][2]

Doing some tests the past couple days, I wiped out the Maya folder and let Maya rebuild a fresh one. Looks like the Animation & Rigging Tools are working fine! Not sure what the culprit is… slowly re-adding my other scripts and plugins back.

So, in case you have some strange issues, try making a copy of your maya prefs folder (usually in My Documents\maya), and delete the folder for your current maya version, relaunch maya and tell it to not copy old preferences (if you have any other versions of maya installed).

Check the official thread created detailing known issues, frequently asked questions, and upcoming features as well as the latest code drops:

ART Master Thread

This did not help my issue, mine gets stuck at 80% and the scene is empty.


Could you please post your report in a new question? It seems to be unrelated to the error that jwift was receiving. That will allow us to track and investigate the issue better.