Download

Rhinoceros 3D to UE4: serious import issues

Hi,

even with Unreal Studio/import CAD there are serious issues in Unreal when it comes to importing from Rhino 3D (i used V6.8 here but assume the same issues with other versions.)

I watched Epic’s video stream some days ago about Rhino and UE. So now with the Studio features we can not only import via .fbx but also use the .3ds file via the new “import CAD” feature.

Lets see if any of these ways works fine:

Here is the simple model in Rhino with UVs assigned:

Now export as .fbx and import in UE 4.20.3. The lightmap generated of UE is overlapping by 23%, as you can see from the error message after the lightbuild. Funny that UE recognises that, but there is no way to fix this in UE.

Ok, lets try the the new import CAD feature from Studio:

Here the 3 surfaces come separately as a “datasmith scene” but still errors (middle version). Now as i like to work with one model and not build collisions for each surface (but just one for the whole model), i actor-merged the 3 static meshes into one (no change, same errors) and tested different settings for recompute normals and so on. Still does not solve the error, just result in different errors: see version to the right:

Even when the generated lightmap in UE seems kind of OK and reports no errors after lightbuild for the import-CAD versions, there are some serious errors as you can see here:

Now I really dont know how to search for the error. Playing with all the variables on export and import seems like a waste of time. Is there any way to track down the issue?

Enclosed are the files.

Can you file a bug report? We’ll take a look at it.
Report Unreal Studio bugs here: https://unrealstudiohelp.epicgames.com/s/article/How-do-I-report-a-bug

We’re improving our tesselator but for now, as a work around, turn on at least one render viewport in rhino, and save the file. This will force our importer to use rhino’s mesh

thanks for youre response…

@ kenpimentel: i created the bug report as requested.

@pierre-felix: as you can see from my first pic/screenshot (bottom half) i have had turned on one render viewport already ( i always work with one on) and also saved during having it on. so that cant be the problem’s source i guess.
As the model looks fine in Rhino, but not in UE the problem should be in UE i guess. as even the dynamically lit model has errors, it may even be that is has nothing to do with the lightmap??? apart from the fact that UE creates wrong lightmaps as you can see for yourself if you import the fbx file and let UE do the lighmapping.

Ah ok that’s good information. We will take a close look!

PF

I don’t know if this is related to your problem, but I have noticed that unit conversions can significantly affect the geometry on import. Unreal uses centimeters, and I have found that making sure my rhino file is in centimeters often produces better results. This is only a guess but perhaps datasmith tolerances are applied to the raw numbers as if they were centimeters, and only then scales the dimensions instead of the other way around.

The model in Rhino looks to have some issues.
What Rhino is able to tessellate does not look good either.
See attached picture.
I’m not sure UE4 can do miracle.

There are some serious problems with mapping textures when I try to import a 3dm file. Some of the simple mapping types are working, but unwrapped objects don’t work at all. It’s a pity that it’s unusable at the current stage and I wonder if it will ever be usable as it should.