Download

RHIGetAvailableResolutions works in a Packaged Game in c++ but not when used in a BP

Ok I just want to get some staff views on this problem, Rama posted it on answerhub and there has been not even a response.

In one sentence its this : RHIGetAvailableResolutions works in a Packaged Game in c++ but not when used in a BP node via plugin. The BP Plugin version works in Editor builds.

ANSWERHUB POST

I am sure the problem is more complicated than flicking a bool, so I think it deserves attention, also Rama is one of the strongest community members and we need to respect his work.

I am by no means blaming anyone , I just want to see this problem resolved :slight_smile:

Cheers !

Yes, I also see some bad behaviour when use r.setRes from Blueprints as well. These are very basic features for ANY engine and must be addressed.

Did anyone from Epic see this. Not even one line to say: “Yes I will look into that…”

Hi Midnight640,

We have someone looking into this. I apologize for the delay.

Thank you, I hope it gets fixed for 4.3

Edit: Just a suggestion why don’t you (the programmers) add it to the stock blueprints. It is hardly a day of work for a programmer (and Rama has given the source code) and EVERYONE will love this addition.

Epic if you’d like me to submit a pull request I can,

but the issue is that the RHI is returning false when used inside a shipping build inside a blueprint node.

It works great in the raw C++ though!

Full details here:

https://answers.unrealengine.com/questions/63029/rhigetavailableresolutions-works-in-a-packaged-gam.html

Hey Folks,

We actively monitor the BUGS section of AnswerHub, no need to additionally post here. The task of monitoring everything is pretty broad, and having information in 2 places just slows down the response time.

Sorry this one took 14 days to respond to on answerhub.

Cheers!