Revit > Max > UE4 Strange UV issue across entire scene (complex problem) 4.19

Hey guys,

I’m bringing a Revit model of a building interior into Max using link FBX, then Datasmithing it to UE4 in the standard way. My materials show up correctly in Revit, show up correctly in Max, show up correctly in UE4. Just to confirm, materials are set and sized correctly in Revit using real world values (a 4 inch brick is set to 4 inches).

I’m attempting to set up the Master Material > Material Instance workflow as advised at Unreal Academy and in Tom Shannon’s book. I understand the benefits of this so I attempted to re-build two of our materials this way. Worked great except for a major UV issue.

The issue is essentially some of my materials in UE4 (those brought in by Datasmith) have arbitrary UV scaling, and some do not (see attached images). So when I build my new materials using the SAME texture image in UE4, the scaling will be correct sometimes and other times be completely off. The main one I’m testing was off by a factor of 8 (so I solved by scaling my material by .125) so I feel like this very specific value is there for a reason…

This is making the material re-building process overly complicated and confusing since some textures might need to get scaled, some don’t, and no rhyme or reason I can see for the difference. Also in the future if some behind-the-scene arbitrary scaling is needed, can it be done to UV’s rather than in the material?

Also, when opening up the Datasmith file in Notepad I can see this in the code, and I suspect this is part of the issue. (notice the .125 values again?)

<Material name=“TestMaterial”>
<Shader name=“TestMaterial”>
<Diffuse tex=“CT-89_2_2_Tex” coordinate=“0” sx=“0.125” sy=“0.125” ox=“0.0” oy=“-0.125” rot=“-0.000083” mul=“1.0” channel=“0” inv=“0” cropped=“0”/>