Revit Datasmith - Cannot find static mesh error

I am trying to get a Revit file into Unreal Engine 4.27.2 using the Datasmith export and import tools. However I am getting the same error on every single Revit file I have tried, including the sample Revit project files from Autodesk.

The error message is “Cannot find static mesh …” multiplied by the hundreds or thousands.
I do get all the textures, cameras etc imported.

While this question has been posed a number of times in this forum, the only answer I have found to solve others issue is that the _Assets folder created by the Datasmith export must be in the same folder as the Datasmith file and have the same name. This is not the problem I have.

I have also tried placing the UE4 project folder in a single letter named folder in the root of one of my drives thinking it had to be about file and folder name length. This did not solve my problem.

Appreciate any pointers to solve my issue, thanks.

Kim Baumann Larsen

SOLVED: The solution was pretty obvious. I installed and used the wrong version of the Revit export plugin (the one for Unreal Engine 5). Switching to the one for 4.27.2 solved the issue. You need to manually select Archived Versions on the download page and select the version of Unreal Engine you want the data going into.