Download

Return to the Main Menu after laoding the PrimalGameData_BP

Do you know why this happens? Everytime I load my mod (doesn’t really matter what I edited), the game returns to the Main Menu when trying to load TheIsland. I think it has something to do with the game mode, but I’m not sure. Here a screen with my world settings:

Unbenannt.JPG

I even tried itr without the game mode override or the generic mod ones, nothing helped… Any ideas?

Try removing (for testing - you still want it to be there when cooking/uploading) Force Load Map Name in world settings.

Alternatively you can do what I do is load up the default test map, and have it load your mod’s gamedatabp (in world settings: primal game data override) and you can leave your own generic map alone.

That’s interesting, when I load up the test map everything is working, but as soon as I try to run the generic mod map with the standalone version, the game freezes when loading the Landscape sublevel. Another thing that’s new is the freeze of the editor when I’m “loading” the map with the viewport.

I always recommend clicking the arrow to the right and launching standalone - if the launch happens to crash, your editor wont crash with it (which tends to cause corruptions in the editor and why many people likely are having to reverify a lot more than they should). As for why that generic map is doing that, I don’t know but maybe its best to start a new generic map from scratch. All you need to do is create a new level, change its gamemodeoverride, change its map name override, and throw in a global process blueprint in the scene outliner.

Will try that out. I don’t know if it’s important but I get this error message everytime I open up the editor. Is it essential for the game to load?

ccfdaf3a0f8440e756d56359f8f2cb788c024737.jpeg

I had this same issue happen to me Tried making several blank mods. The issue went away when i stopped trying to use the PrimalGameData_BP_Generic and used a new subclass of the PrimalGameData_BP that the game uses.

Did you still use the generic game mode file?

The only thing I pulled from from generic was the map. I used the actual gamedata and gamemode that the game currently uses.

I only see errors like that if I accidently edited a core asset or if the editor crashed. They shouldn’t affect your work but they will go away when you verify.