Retargeting projects error: Visual Studio 2017

I’m fairly new to Unreal Engine and have a quick question about an error I’m receiving with Visual Studio 2017 when creating a new C++ project.

Installed software:
UE 4.16.2
Visual Studio 2015 Community
Visual Studio 2017 Community with Microsoft SDK 8.1 installed
CodeWorks for Android 1R6u1

I followed the steps in “Setting Up Visual Studio for UE4” from: Setting Up Visual Studio for Unreal Engine | Unreal Engine Documentation

What I have done:
Created a new C++ Project.
Basic Code
Maximum Quality
With Starter Content

Once Visual Studio 2017 launches I get the following dialog box:

I changed the Retargeting to the following and clicked ‘OK’

Then I receive this message in the output in Visual Studio 2017.

I’ve tried different combinations with the same result.
Is this ‘normal’ or do I have something configured wrong.

Thanks for the help.

You need to generate VS 2017 projects instead of retargeting 2015 ones.
There’s a setting for this in DefaultEngine.ini:


Also make sure you have all the required packages for VS 2017:

  • game dev with c++
  • desktop dev with c++
  • desktop dev with .net
  • windows 8.1 sdk in individual components

I already have the VS 2017 stuff loaded. I would like to have VS 2017 be the default for all projects, not just change the DefaultEngine.ini within the already created project. I just don’t understand why I’m getting the “1 failed” message just from creating a new C++ project.

I think you can also add the Compiler=VisualStudio2017 in the appropriate section in the Engine/Config/DefaultEngine.ini file to make it default for all projects.

The file C:\Program Files\Epic Games\UE_4.16\Engine\Config/DefaultEngine.ini does not exist

oops I meant BaseEngine.ini

Thanks for the help but I can’t find a good place to out the line.
I’m going to stick with VS 2015 until Epic fixes this.

In this section:

Have the same bug, editing BaseEngine.ini, not helping. (UE 4.16.2)

I just can’t create new C++ project for VS2017… What now?

I dont have retargeting errors, but project names are: UE4 (Visual Studio 2015), MyProject (Visual Studio 2015)

Should i uninstall 2017 and install 2015? really?

Can it be because i have also installed v140 toolset for VS2017? should i delete it? May be UE4 project creator sees v140 toolset and dont even count BaseEditor.ini Compiler option? (just tested: YES, it worked, i deleted VS2015 toolset from VS2017 installation, and now UE4 creates project properly - so its obviously a BUG).

If it’s a bug then you should post a bug report on answerhub.

Have you tried:
Edit -> Editor Preferences -> General -> Source Code -> Source Code Editor
Set it to “Visual Studio 2017”?

You also could try:

The batch by idbrii. But use -2017.

I re imaged my PC to just windows 10. Installed vs 2017 and UE 4.16.2
Its working now.