Retargeting problem (Floating character and deformations)

Hi! So I am retargeting animations and everything is going pretty well so far. However I am having issues with the pelvis. The root bone is supposed to be set to animation and the pelvis to animation scaled. The root bone is fine but the pelvis (when set to animation scaled), is deforming my character. He is also still floating, no matter what I do.

So here’s what my skeleton tree looks like

Here’s what the animation looks like. You can see his body is curved and stretched

If I set the pelvis to skeleton instead of animation scaled, the body now looks fine, but I’m not sure doing so will work in game (there’s a reason why it must be set to animation scaled I guess)

What should I do? How can I set the pelvis to animation scaled while avoiding deformations? The exemple screenshot I gave you isn’t that bad but it really looks weird for many other animations. And besides, no matter what I do the character keeps floating above the ground. :confused:

Shouldn’t you set animation scaled on your hip bone instead? I’m pretty sure the mannequin doesn’t have a hip bone, but you probably shouldn’t retarget the pelvis bone of the mannequin to the pelvis bone of your rig if you’ve got something that deforms the character before that bone (hip bone).

For the floating you can change the collision in the physics asset so it lines up with the actual feet. If the character is still floating after that you can export a mannequin animation as an .fbx, import it but with an offset in the import translation, so it imports with the feet under the ground. Then retarget that animation and experiment with the settings until you get something that looks good for your character, then you can use that value when exporting and importing a bunch of animations you want to use. It kind of feels like a hack but it works.

1 Like

Hi, first thanks for your reply. How can I change the collision? I’ve only got 2 options in the physics pannel : Enable per poly collision and Physics asset, neither seem relevant. :frowning:

1 Like

You need to double click the physics asset, then scale and move the bodies for the feet so they are aligned.

It’s working now! You were right, I actually did a couple of retargeting mistakes with the hip and the pelvis, now my character still appears to be floating in the animation preview window but he’s touching the ground just fine in game. Thanks for your help. :cool: