Download

Retargeting Mixamo In-Place Animation To Epic Skeleton

Introduction
Since Mixamo has just removed the option for UE4 download, I want to make a quick tutorial on how to get any in-place Mixamo animation working on Epic Skeleton.

Compiled Project Files
First off here is a compiled project showing off one of the issue with Mixamo animation and what it look like when you fixed it.
Dropbox - Error

Epic Skeleton Without Root
https://www.dropbox.com/s/wsr11a78v2u8yv8/SK_Mannequin_noroot_two.fbx?dl=0

Videos
Short Intro. Tried making a full tutorial video but took too long to edit.

General Idea
The main idea is to remove the root and IK bones from the UE4 Manniquin (Epic Skeleton) then upload the NoRoot Epic skeleton to Mixamo for animation. After you have the animations for the NoRoot Epic skeleton, you add back the root node and everything should be compatible with the original UE4 Manniquin (Epic Skeleton).

Unreal Steps
Step 1) Create a Third Person Blueprint project
Step 2) Export UE4 Manniquin (Epic Skeleton)

Maya Steps
Step 3) Open Maya and set World Coordinate to Z-up (Most important step)

Step 4) Import UE4 Manniquin into Maya
Step 5) Unparent the ‘pelvis’ bone from the root (If the mesh get rotate 90 degree after unparenting then your World Coordinate is in Y-up, do step 3)

71723ff80705bd7b7356ef6458026d0f407bc871.png

694c2f97306b6fcf1deee7a725a6ca7fba8508b1.png

6cc91807e6af0a6e30206909be6e76fe4b1e4374.png

Step 6) Export the new skeleton as FBX, call it Manniquin_NoRoot (You can call it any name)

Mixamo Steps
Step 7) Upload the Manniquin_NoRoot to Mixamo

662299b36ee668c6441be9ff77524add9e38c0b2.png

Step 8) Choose in-place animation for Manniquin_NoRoot. Only in-place animation will work for this method that I am showing you. Root motion animation require manual retargeting inside MotionBuilder

9d2a14e729c06a3947b3c1ff210b0dfc08a8d800.png

Step 9) Download animations for Manniquin_NoRoot

790e0b5453006648fd2d1f98ffb2f6700c131aa6.png

Maya Steps
Step 10) Import the original UE4 Manniquin with root

2333d8bf7d536da42ba27e70ef8d05a26881c036.png

Step 11) Import one animation downloaded from Mixamo to original UE4 Manniquin

174dfb7878c47be8abc40c2fd1261639efa345fc.png

Step 12) Select the entire skeleton, and export animation. The animation should be now compatible with the Epic Skeleton.

Step 13) Import animation into Unreal Engine 4

Result

Transfering Root Motion from Mixamo Animation to Epic Skeleton

**Update 5/27/2017: Add a video (not mine) on how to transfer root motion using Blender

Mixamo to Blender to Unreal Engine 4 - "proper" rootmotion animation - YouTube

General Idea:**
The root motion data in Mixamo animation are stored in the Hip bone Y-translation. Using Maya Graph Editor, you can copy the hip-bone Y-Translation into the Root-bone Y-translation. This should result in a working root motion animation for Unreal Engine.

Result:
Here is an example of a hitreact root motion animation. The root motion is controlling the character backward movement.

Here is an example of a crawl root motion animation. The animation cause the character to move across the entire room.

Very nice approach! I used to use Motionbuilder instead and creating control rigs for the models but your approach is much cleaner

“Step 7) Upload the Manniquin_NoRoot to Mixamo”

On import to mixamo, my skeleton looks wrong: http://imgur.com/a/Fjua4
i.e. the skeleton seems to be flat on the ground. Any idea what can cause that?
Everything else seems normal, e.g. when I add animations, they work correctly.

Also,

I notice that the imported Mixamo animations seem to have a slightly different alignment / foot placement, than the original mannequin ones, i.e. when placed as a mesh into the level at 0,0,0 the old animations make the mannequin go 2-3cm below the surface. Mixamo ones look fine. I guess the fault lies with the original mannequin animations?

Thanks for the tutorial @kelfire. I’ve tried similar approach in past with Modo but I couldn’t get the modified skeleton to work properly when I get the animations back to ue4. I now tried to replicate what you did by removing Root and IKs but when I do that, I don’t even get the “in place” option on Mixamo and animations looked like they were root motion anims without the actual roots moving.

Would it be possible for you to upload the modified SK_Mannequin_NoRoot.fbx here? According to UE4 EULA, it seems that sharing modified mannequin is allowed as it is located in Template folder within the engine installation directory (it’s in <ue4 installation folder>\Templates\TemplateResources\High\Mannequin\Content\Character\Mesh*). I’ll quote the relevant parts from https://www.unrealengine.com/eula:

@Hoaxx Are you sure you have the World Space set up to Z-up before importing the Manniquin.fbx? Having it on Y-up before importing the Epic skeleton will cause a bunch of weird error like bone rotated 90 degree and floating animation. Changing World Space doesn’t work once the mesh+skeleton has been imported.
I also have Advance Option->Axis Conversion->Up Axis = Y in the FBX export, not sure if that would affect anything.

@0lento Yeah I uploaded the SK_Mannequin_NoRoot.fbx to Dropbox and added a link in the first post. Some old Mixamo animations doesn’t have the “Inplace” option, but the newer stuff like the magic, bow, sword+shield, and rifle pack should have the in place option.

Thanks for the tutorial and the FBX Kelfire.

I havent used Mixamo animations in a few months so this may be the way to do it now.

Here is the way I did it last time:

  1. Create character in Fuse and upload to Mixamo
  2. Target all animations to this character
  3. Download animations “in place” and “for Unreal” or “FBX”
  4. Import animations and character to project
  5. Use Unreal retarget manager to retarget all animations to UE Mannequin (Mixamo character is in T-pose, Unreal is in “A” pose)

If this still works, there is no need to modify rigs, or use any other package.

-J

The main benefit of this method here is, you don’t have to worry any more about differences in the poses (A vs T or slight differences in fingers etc).
Also it fixes the dreadful floating problem - for me the old method always resulted in the character being 5-7cm above ground, which I had to fix by hand.

Also, Mixamo dropped the “for Unreal” format, so only generic FBX is available (which of course works fine - except you can’t export characters from fuse with the UE4 skeleton anymore).

Yes, that was it!

Thank you!

I just tested the NoRoot mannequin OP posted. You can actually get the animations to unreal without using Maya etc.

If you just upload the provided mannequin to Mixamo and export with the animation with skinned option/character, you can import the skeletal mesh + anim to UE4, then you can retarget the new animation to UE4 skeleton by right clicking the new anim sequence. Since bones and proportions match, you don’t have to manually setup anything and retargeted anim seem to work fine. I just tested this with one anim though but seems to work fine so far.

I tried to get the NoRootMannequin anims to stock UE4 mannequin with Modo but it didn’t give me the correct results (could be just my inexperience with animations on Modo), there’s few more clicks when you do it on ue4 side but it’s still fairly quick operation.

I did some further testing with approach mentioned on my previous post. It seems to work and it’s actually faster too as I can just mass select all animations and retarget them automatically inside UE4 for stock skeleton.

Yep, that method is faster. Can retarget a whole pack of animation at once.

Thanks for making this video!

I am trying to use animations from the unreal engine marketplace. Any solution for that?

Don’t they already come with an UE4 skeleton? What issues do you have with them exactly?

Well, I am using characters from Mixamo Fuse. The rig on the characters from mixamo are not the same rig as the UE4 skeleton because they removed the unreal engine download option.(So i have to use the standard FBX download) I was able to rename the bones and add a root bone with 3ds max using a maxscript. When i import the character into unreal engine to use the epic skeleton, the rotation of the bones are screwed up(Z-up is on) and i get warnings about bind poses.

i get an error like this photo
https://community.mixamo.com/hc/user_images/h_ZajslomXJBos5Un2NmZw.png

I tried to upload the provided no root mannequin to mixamo, but first automatic recognition failed (i needed to map the bones manually) second time it said upload was successfull, but still my character did not appear (said: something is wrong, contact support)
*edit: i just had to keep trying, seems it worked third time.

I just want to confirm that this method works well. thanks for the no_root skeleton and the tips.

now… what would be the fastest method to save all the animations from the site? is there a torrent file maybe?

So what hero wants to get all of the Mixamo Anims convert them to UE4 then set up a torrent for us. :slight_smile:

Since they have been giving them away for free for years now they are basically shareware at this point.