Download

Retargeting animation changes scale of receiving skeleton

I’m trying to retarget an animation from a Mixamo animation to a custom character I made in Blender.
The retargeting works fine, all the bones move the right way in the final animation, the only problem is the the animated mesh is scale up 100 times.

These are the two meshes, on the left is my custom one, on the right just a placeholder from Mixamo:

I haven’t rescaled anything in this screenshot, I just dragged and dropped the two meshes in the world and their scale is fine.
Now if I drag the retargeted animation in the world, to check if it works, the animation plays fine, but it looks like this:

It’s some 100 times bigger than it’s supposed to be.
Note that if I retarget the Mixamo animation to the UE4 Mannequin, the mannequin’s scale doesn’t change when I play the animation, and if I try to retarget a standard animation from the mannequin to my mesh, my mesh’s scale doesn’t change. So the problem seems to be in the retargeting from Mixamo to my mesh.

The skeleton tree is set up like this:

Changing the root translation to Animation Scaled doesn’t change anything. Also changing every bone to Animation or Animation Scaled doesn’t fix the issue (but the animation looks bad).

How can I fix this?

I am having similar results here - I import a MakeHuman character from blender, in Blender the character is scaled to 179m and when I export/import it looks fine, when scaled 0.01 - I import the character with the exiting skeleton and that goes well also. The idea is that all characters should share the same skeleton/animations…

But when I apply the shared animation BP the entire character is scaled 100. I figure that there is some correction done by the animation or that somehow the character still contains some scale parameters? I tried various options, scaling on Blender export, on UE4 import, changing the units/scale in blender… etc. nothing seems to help!

Probably due to whatever issue is going on with Animations not scaling when you change the scale of an existing/animated asset.

You have to manually scale each frame of the animation and export the new animation FBX.

I solved this issue in blender, I just had to apply all transforms to the mesh in Blender. Select the animated object, then click Object > Apply > All Transforms.
I also changed the Translation retagerting of the first three bones in the skeleton tree (human_001, root and pelvis) to Animation Scaled to make it work properly.