Download

Retargeting all animations of a skeleton fails, but all individual animations succeed

I tried retargeting a skeleton from an imported Marketplace asset to my “own” skeleton. It would fail every time. I’ve tried things like “resave-all” and cleaning the project … to no avail:

> LogDirectoryWatcher: A directory notification failed for ‘…/…/…/…/UnrealProjects/SurvivalGame/Content/’ because it was empty or there was a buffer overflow. Attemping another request…

It was a pack with 9 weapons, and the animations going with them. So I created a temporary project, migrated my skeleton to it, and then all the animations for each weapon separately. Every time, the skeleton of the imported pack would be overwriten, and I would tell the editor to retarget the pack skeleton to my skeleton, and it would work. So I have basically done the exact same thing, only in 9 goes instead of one, and I did not get an error.

It seems to be a “resource problem”, but I have 32GB, and my PC never went over 12GB. There must be some hard limit that gets reached in this case, but since I have plenty of RAM, I’d like to raise that if possible, as the “work-around” is a PITA.

How do I raise whatever resource limit is preventing me from retargeting more animations?