Retargeted animation sequences work well in preview but not in PIE

Hi,

I’m a beginner of UE5. I got some retargeted animations of my character following steps in official documentation. They look perfect in preview, both animation sequence and blend space. But in PIE, the legs of my character are frozen when running, even with all other parts of the body moving correctly.

Another thing is, the retargeted ABP is always warning me hierarchy discrepancies for some bones of the upper part of the body like neck, head and fingers. It says ‘different parents on CR vs SM’. I’m not sure if this has anything to do with my first problem. But I still cannot fix it by myself.

I really need some help now and I’ll really appreciate it. Thanks!

Hello YifanDaniel,
It seems you are missing speed, then the blend is nor working well

Thank you for your reply Alberto.
Sorry I didn’t explain it clearly. My character is moving forward when PIE. It’s only the problem of animation. The arms are waving but the legs are not. Same thing is happening when jumping. The legs are in an unnatural posture.

It’s working well in all of the preview of animation assets and blend spaces.
I should have posted with pictures.

Thanks.

But I guess you are blending animations, and the legs are not receiving the correct value… I think

Ok look, this is what I think is happening to you, at some point you are loosing a variable
So you can see it perfect in preview as normal, and in-game you can see part of the blend working:

speed

I get it. But I don’t think it’s the problem because I copied the ABP from Manny, the default character of UE.

Still I agree that I should check out my ABP because it processes and integrates all the animations when playing. Your reply is enlightening. Thank you.

Yeah but don’t copy paste, try to retarget the whole animbp:

like this!

Hey Alberto, sorry for this late reply.

Thanks for all these details! But I did retarget my ABP following these steps.
And today I tried to modify my IK Rig excluding some of the bones that seemed needless to me. Retargeted, and failed. And I repeated retargeting in another project to see if there were any related project settings I altered before. And failed, too. It’s neither the problem of my character because I already tried another model from a different source.

Next I may learn to create a new ABP by myself. Hope that will do.
If you have any idea of where the problem may be, please tell me.
Thank you!!

Alright, I’ve found the problem. It went well after I used the ABP from UE4 Mannequin. There must be a mismatch between my skeleton and the new version blueprint. Though I don’t know what it is.
Now I can carry on with my project.
Thank you again!

1 Like

Yeah, I’m glad! ;D