Reset to Default causes setting to freeze and become unchangable

I was messing around with the FirstPersonExample map, and I got to the blueprints of the FirstPersonCharacter. I clicked on the CharacterMovement(inherited) component in the component box on the left. Changed some of the fun values like Gravity and Jump height and stuff around. That worked, no problem. Then when I pressed Reset to Defaults for those values, it stayed the way they were. Visually, it looked like the default value, but during play it was all still the old value. You could change the value in the box and try again, but it would still be that value you had right before you pressed Reset to Default. I tried this with other values like Walk Speed, and it works the same way. Everything is fine until you press Reset to Default. You can change the speed up and down, and this all reflects correctly during play, but once you press Reset to Default, it gets stuck with tha This problem persists through restarting the editor. It seems to be saved that way now. I still can’t change it.

I’m on windows 8.1 64 bit, and my unreal editor version is 4.7.2. I just downloaded it today.

Screenshot:
Imgur

So for now, I guess I have a first person shooter where your character moves at a centimeter per second and when he presses jump he flies into the air forever because gravity was -7000 when it froze there.

Hi McSchwartz,

Thanks for the report! I was able to reproduce this in 4.7.2 as well as our internal build, so I have entered a bug report for the developers (UE-11483). I’ll let you know when I see any update on this bug. In the meantime, I’m going to see if I can find a workaround for you as well. Thanks!

I figured I should mention, in case you weren’t aware: you can delete the Character Movement component and create a new one with the Add Component button. This way you only need to replace one component instead of the whole project while we figure out what’s happening here.

I couldn’t delete it because it was a root component sadly, but maybe that’s partially the cause? I was able to navigate to the place to create a new CharacterMovement component, but now I have to install visual studio 2013.

I apologize, it looks like you can no longer delete and replace the Character Movement component in 4.7.2. You might just need to create a new Character BP. It’s more work than just replacing the Character Movement component, but it’s still better than replacing the whole project. I’ll keep you up to date on the progress of the bug report.

Okay, the developers informed me that this is simply a bug with the reset button. You can work around this for now by manually setting the archetype property back to what it was before you hit the reset button, and then continue on from there (never using the reset button again).

What exactly do you mean by “manually setting the archetype property”? Do you mean in the Details tab on the right, here? http://i.imgur.com/I5vzgbm.png
Setting that number by typing it in still doesn’t resolve the problem. Is there anyway to recover from this short of starting a new project?

Not that that’s a problem for me, I hardly made any changes to the template project. But just for other people, is it possible to recover from this?

Yea, typing in the number and hitting enter (rather than touching the arrow button) resets it if you haven’t already used the Reset to Default button. Since you have, you’ll first need to enter a different number, compile and save, and then enter the default values manually. That should fix it for you. Let us know if it doesn’t!