Reset Particle Emitter System from Blueprint?

I want to be able to enable/disable a particle system from blueprint. The Particle System itself is a component in a blueprint. When I enable it, it should start from 0, and when I disable it it should stop emitting new particles, but let the remaining ones die naturally.

Stopping the Particle System with “Deactivate” works, no new ones are spawned and the existing ones are dying slowly.

But when I activate the Particle System again, it starts from “already many particles exist”. My Particle System is some smoke, and the smoke is just suddenly appearing on activate, instead of slowly spawning more and more particles.

I tried setting “Reset” on deactivate and on activate, bot both doesn’t affect it.

How can I get the result I want to have?

hi, i have the same issue, any idea please ?

It does start from the beginning of the effect. Your smoke either spawns too fast and is visually creating the effect of already being there, or your emitter has a “warm-up time”, a parameter which causes it to tick a while before enabled.