reset Flipflop

I made a control sequencer with stop, replay and pause/unpause command (a keyboard command switches flipflop A to pause and B to play[unpause]).

The problem is when I pause, stop, replay and press pause, I need to press twice to pause for real. The flipflop maintained the last keyboard command before the stop. There is a way to automatically reset fliflop back to A after the sequencer being stopped?

I didn`t discover a way to reset BOOL variable value back to zero too… that could be a solution?

Can you post a picture of how it’s all connected?

Hi CDMcGwire, sorry for the delay in answering.
Here`s my BP

By having both a flipflop and Sequencer, you’ve created a timing issue. If at any point they update separately, such as with your replay and stop commands, they might go out of sync.

Instead of using a flipflop (and even more direct than my earlier suggestion) use the “IsPlaying” function of the SequencePlayer and a branch to control the pause/play function, as so:

That is a big struggle for me. How did I reset or alternate a boolean value? In my attempts, once I injected a pulse in a boolean variable, it maintains this value forever.

PS.: I didnt find this node "GetPlaybackSpeed"... theres some other option with similar funcionality?

Here’s the function I was talking about. I used the wrong name. I’m going to put a blueprint example together when I get home tonight.

Perfect! It worked. So simple!

Thank you very much sir