Reset camera roll in viewport


After doing a bit of googling around and research here and there I really couldn’t find a simple answer to this issue, I have a few workarounds in mind but it still bugs my mind.

The question is simple, how can you reset the viewport camera’s roll?

Steps to recreate this annoying situation one could find himself in:

1 - Attach a camera to a player pawn

2 - Find a way to have the player pawn roll after you press “Play”

3 - Use Shift-F1 (by default) to free the cursor and then eject from the player’s camera.

4 - Enjoy being stuck with a rolled camera that has a very confusing way of working

Here is a screenshot of how it was for me, I managed to get the actor spinning into the air but ejecting from it to inspect the surroundings got me this very, very strange point of view, the landscape isn’t rotated by the way as you can see in the details tab, you can also notice at the bottom left of the viewport every single axis is all over the place.

Pressing E and Q doesn’t take the roll into account so it doesn’t go “upwards” from your perspective (it goes upward according to the Z axis)

Pressing A and D however does take the roll into account (and so they also make you go up or down a little, depending on the rotation)

Doing an Alt + Right Click actually made me locked into negative Z axis and I could still use the right mouse click to turn around (but only in negative Z axis)

After fiddling with Alt + Right Click (and dragging around for a while) I eventually managed to fix it but I’d still prefer if there was a “reset camera rotation” button to avoid all of the spinning before you can get it back to be right, which I cannot seem to find.

Another workaround would be having a camera set somewhere in the world and “piloting” it then ejecting from it, but it gets you somewhat far from where you were and that camera wouldn’t really have any other point besides of that one.

Same problem here, There is some gimbal lock issue on the camera. It happens to me on archviz scenes when working on a “top-down” perspective view. My work around is to spin it when in top-down and focus (F) on an object until I it gets back to normal.

If you are looking though an exising camera (not just in the viewport) have you tried this button?

ALT + Right Click worked for me, thanks! (UE4 v.26.1)


i am having the same problem but not working

Anyone having this issue… Select a random object in your scene, then press F. The camera should snap to the object, then hold ALT + LMB and drag the mouse to rotate the camera around the object and it should snap back to normal.


That worked for me! Thank you!