[Replicable] DemoNetDriver out of date

Link to Project Demonstrating the Issue

I am trying to replicate demonetdriver/replay tutorial here, but my result is very unsatisfactory.
During Replay in 4.17.1, I get 6-8 warning messages per tick about DemoNetDriver being out of date.

[2017.09.18-14.36.19:865][250]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date DemoNetDriver: DemoNetDriver

During replay I (spectator) cant move, and though physics objects fall, they do not follow same path as in the recording (even if the Static Mesh Replicate Movement is True). Player is stuck in one place, does not move, despite having all replication settings on.

I have tried declaring streamer type in config file


as well as in build.cs (in memory type) suggested here, but both resulted in same issue.

Is it a bug? Does 4.17 use different streamer? Appreciate any info


Daily bump #1

Have you figured it out? Same problem on 4.18.3…

It is target for 4.20, fingers crossed. Yes the git hotfix works, though replay system seems to have major issues at the moment.

The user above made a bug report:

It looks like the fix is not in the current version, nor is it targeted for the upcoming engine version. I recommend you try this temporary fix:


It’s interesting - I definitely have many different issues with it, but everything was working okay until I tried to A) call stopdemo in BP which caused an instant crash and B) make a “play all replays” function which caused the behavior you described on the second replay. Bummer.

I’m having this issue in my game in 4.18… the strange thing is though, it seems to work just fine in ShooterGameSample on 4.18. What’s up with that? I have not found the culprit yet