Rendering sequence Crash: Assertion failed: NumElements % Params.NumArrays == 0

Hello,

For a few days I am trying to debug the systematic crash of my rendering sequence.

The displayed error is :

[2023.02.23-14.23.36:832][ 6]LogWindows: Error: === Critical error: ===
[2023.02.23-14.23.36:832][ 6]LogWindows: Error:
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: Assertion failed: NumElements % Params.NumArrays == 0 [File:D:\build++UE5\Sync\Engine\Source\Runtime\RenderCore\Private\UnifiedBuffer.cpp] [Line: 440]
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: NumElements () must be a multiple of NumArrays (Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x000000cb00000005
[2023.02.23-14.23.36:832][ 6]LogWindows: Error:
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2a52da7d ucrtbase.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2a513b7b ucrtbase.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2a513970 ucrtbase.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2a5136af ucrtbase.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb97144a73 UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb9711a32e UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffbf8862a26 UnrealEditor-RenderCore.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffbf87df864 UnrealEditor-RenderCore.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb74174b0a UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb741dede8 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb741de4de UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb7406b316 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb74bb2d04 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb74b7f967 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb74b97ff1 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb74b9fe18 UnrealEditor-Renderer.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb96e62fdd UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb96e6352e UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffbf871f804 UnrealEditor-RenderCore.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffbf8723b54 UnrealEditor-RenderCore.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb97585342 UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffb9757d230 UnrealEditor-Core.dll!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2c1126bd KERNEL32.DLL!UnknownFunction []
[2023.02.23-14.23.36:832][ 6]LogWindows: Error: [Callstack] 0x00007ffc2d04dfb8 ntdll.dll!UnknownFunction []
[2023.02.23-14.23.36:833][ 6]LogWindows: Error:

I have tried a few things to solve it without success:

  • Updated my GPU Drivers (Nvidia 3090 rtx 12 GB)
  • Delete my assets one by one to find the problem
  • Turn off Nanite on my meshes (except those from Quixel)
  • Remove Ultra Dynamic Sky and Weather
  • Change Camera
  • Create a static Sequence with a new camera

I have another Map (less complex) on the same project with another sequence and the rendering is working fine.

If you have any clue to find a solution, I will appreciate.

Best Regards

Hi, same error here! , did you solve this?

The same problem. Also have a UDS sky and weather, some standart foliage, and also procedural foliage spawner, grass. Changing nvidia drivers from studio to game do not help. Have you solved the problem?

Edit: So, I disabled grass in landscape material and it started rendering. Although that looks like some bug honestly