Download

Rendering a movie from commandline quits with no progress

I’ve been attempting to generate a movie from my level sequence to no avail.

Using an almost completely empty project, with only a simple asset imported to have something to recognize in my render, I have built a level sequence and can render it fine within the editor.

When I attempt to use the Automated Level Sequence Capture, as described in the documentation my game opens, the camera and assets snap to the first frame of the level sequence, and then the editor closes without running the sequence or saving any movie.

There is no output at all to the shell to indicate what might be wrong. I have tried several permutations of arguments, attempting to reduce them down to only the bare minimum, to see anything render, but cannot get even the simplest result to save.

Any example of someone successfully rendering frames or movie files from the commandline would help me a ton.

Do you have the Movie Render Queue plugin enabled? We recently fixed an issue that will be coming out in 4.26.2 that caused the Automated Level Sequence Capture to not work if you have Movie Render Queue enabled. One possible workaround until 4.26.2 is released is to disable the Movie Render Queue plugin. Here’s the details of that issue:

Also, Automated Level Sequence Capture will eventually be deprecated as we’re putting all of the development efforts into Movie Render Queue. Here’s the documentation on that:

Thank you so much Max. That worked on my first try.

I was prepared to download older engine versions and expected to spend several hours wedging this out, and you gave me the linchpin. Now I get the freedom to focus on other problems.

Does the Movie Render Queue support launching renders from the command line, or is it only working inside the editor? I’d of course prefer to use the more supported patterns.

Yes it does work from commandline. There’s a livestream here with a lot of information:

And the corresponding slides:

https://epicgames.box.com/s/8zzu8bastvh5h6bdch4p87on2gqk6001

Thanks for your help Max, I was able to get it working using the new system as well.

I hope those slides get distilled into documentation at some point, I don’t know how else I would have found them except for this forum post.