Render Target Preview NOT Displayed Accurately at Runtime.

I’m using a Scene Capture Component 2D + [Show Only Component] node in BP to remove everything but my character. Using the alpha channel of the Texture Sample node in the Material displays exactly what I want it to display, however when shown at runtime (through UMG) the transparency is not applied. What might I be missing?

Some images to show the setup:

Material Setup ^

Previewing Opacity Node, which makes it appear to be doing what I want… ^

What the Render Target is doing @ Runtime ^

and finally, what ends up rendering to UMG in-game. ^

Hey DopamineRush,

I think your issue is you are using HDR and then rendering that again which will wash out your color values. Try unchecking the ‘HDR’ checkbox within your Render Target Texture.

Let me know if you need further assistance.


Just tried removing HDR, didn’t solve the problem unfortunately.

Can you show me a screenshot of the setting you are using on your SceneCapture2D actor?

I tried the different settings of ‘CaptureSource’, only HDR settings had Out A though, I’m guessing I’m missing something here?

Restarted the Editor and it worked? Not entirely sure, just leaving all this here for anyone who wanted to do the same.

Uncheck HDR, and set target Gamma to 2.2

Did this work? If so, post it as a separate answer? It’ll help others facing the same issue.

Yes using the above method worked perfectly