Download

Render Passes break the whole sequencer system when rendering frames?

So… for the last 2 days I was troubleshooting this scene I have to render from sequencer.
At a certain point everything stopped working, like… Events not firing, skeletal animations not working (everything was working in the preview window, but not in the rendered frames)

I’m not expert on sequencer so I googled for solutions thinking that I was doing something wrong, that I didn’t understand something critical about the sequencer workflow.
That’s when reference to a TON of bugs started appearing, people deleting and creating again camera cuts as a workaround to get the intended behavior, deleting the sequencer asset reference on the level and placing it again on the level to get functionality back… and a long list of esoteric solutions.

For my problem… it turns out… when I disabled the render passes, everything went back to normal, everything started working as intended, BP events firing, animations playing…

I guess my question is WHY? WHY a seemingly innocuous render setting completely broke BPs and the animation system for me?

I’ve had similar problems, but don’t hold your breath on getting a response, much less a “why”.

When you say you disabled render passes, do you mean you uninstalled the Media Render Queue plugin, or did you just uncheck enabled for the various passes, or delete the passes entirely? I’ve tried the last two, but those didn’t fix my issues. Basically, for me, it seems that once you fire off a render via Media Render Queue, whether you cancel it or it completes from there on out camera cuts, animations, etc, stop working.

1 Like

Sry for the late reply. I was beyond frustrated with the whole sequencer system when I posted this.

In my case the “solution” was to disable the passes rendering entirely (not the individual passes) and just render the final image. It worked for what I had to do, but yeah. No passes.

Btw I’m using the standard rendering thingie on sequencer not the new plugin.