Renaming umap removes file from editor

Hey everyone.

I’ve been working on a map for the past week and just got around to finishing it. When I tried to load the map with the open level node I ran into a conflict with another file (loading absolute to make it easier for my designers or I would have just included the full path) so I decided to simply rename the file as I have with countless other maps/assets/etc from 4.6 to now.

From some reason, the map disappeared from the Editor when I tried loading another map to work on. The asset is still located in the same directory and showing up in explorer, but I can’t do anything to get it loaded again. I’ve tried migrating the asset to a new project,I’ve validated assets, tried fixing up redirectors, deleting intermediate, saved, and binaries, plus all of the other little ‘fixes’ that I’ve picked up along the way, but nothing helps.

My project comes out in 9 days and I really don’t have time to create a new map, so I’m really hoping that there’s a way to fix this issue. I get that creating a file in a higher engine version and downgrading will prevent the asset from being loaded, but I feel like renaming a file shouldn’t delete it from the editor…

To make sure that the issue could be reproduced, I created a blank test map and renamed it and the same thing happened.

Any help would be appreciated.


Update if anyone thinks it will help:

I tried duplicating a map so I could rename the copy, but the editor wouldn’t let me double or right click on the asset, so I renamed the original and it deleted the copy. Then upon loading the original, the original file was deleted as well…

I saved all modified assets before attempting to click or rename the map, and the map is still in explorer.

I have no idea what I did to cause this issue. I’m using a binary build so I haven’t modified source or anything like that…


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


AH okay, thank you so much! I’ll repost there. I decided to just roll back to a previous build and redo the map, but I’ll report it so you guys can look into it.

Creating an answer to mark this issue as resolved. Thank you Jeff for pointing me to the proper location!