Download

Removing players arms and gun.. in FPS mode

I created a new project in FPS mode…

but I don’t want the arms or gun in my view…

how do I remove them from the default setting ?

I’ve seen hintsa t doing something to the blueprint… but I don’t understand what blueprint I’m supposed to see here…

when I “open level blueprint” there are no nodes…

Search for the mycharacter bp - double click onto it - go to the component tab - delete the arms and all other stuff that you dont want. The level bp is just here for the level that you are working in. All the other bp stuff is made with actor, pawn,… blueprints :slight_smile:

6d06db6befa49d897a16448966d4fa501c5e4c2e.jpeg

great !

BUT… now I fly around without any restriction to movement…

What exactly do you mean? You should just delete mesh and mesh1p, because otherwise you can’t change the camera perspective, movement stuff,… :slight_smile:

Has anybody noticed that this is not a valid way to edit/ remove the arms and gun anymore? I used to do this method in 4.8.3 and now after trying in 4.9.2 to no avail, I backtracked and it doesn’t work in 4.8.3 anymore either. Any idea why or another work around?

Thanks

If you don’t want the gun or arms in view just set them to hidden.

Open FirstPeronCharacter BP.

Under components tab select Mesh2P

Under details panel scroll down to Rendering and untick VISIBLE.

Repeat for FP_GUN in the components tab.

NOTICE, this will still allow you to click the mouse to shoot the gun, just go to the EVENT GRAPH in the FIrstPersonCharacter bp and disable the InputAction Fire node under Spawn Projectile.

You will still get collision but you won’t see the arms / gun and can’t shoot the gun.

Or just move your camera infront of the arms / gun.

Hey

I had a firstperson project setup with a working walkable character. I wanted to reverse engineer the project so that I can learn some more of the blueprint ways. I set up a new firstpersoncharacter and a firstpersongamemode. I followed many tutorials in doing this. But now whenever I press play I start my current viewport view, and not from my characters camera viewport. I checked the worldsettings and my pawn is set correctly to it as well. Any ideas what might be the issue? I’m at a loss, been looking for 2 hours to try and fixit and find whats wrong :confused: Hopefully someone here can help out!

Thanks,
-wes