Removing log linker warnings for deleted files

I’m getting the following warnings in the output log when loading a project:

LogLinker: Warning: Can’t find file
LogLinker: Warning: Can’t find file
LogUObjectGlobals: Warning: Failed to
find object ‘Class

  • the file in question is a tutorial from the simple vehicle template that somehow sneaked into another project (?!)
  • even if I wanted to do it, I’d have to jump some hoops (right?) - as in copy it manually, which I obviously did not
  • the uasset and its folder no longer exist in this project or, what is more likely, never existed in this project

What I’ve tried:

  • Fix Up Redirectors in Folder (before and after deleting the folder)
  • Removing Intermediate and Saved folders from the project
  • Removing the 4.20 folder from AppData\Local\UnrealEngine and letting the engine rebuild it (that includes the ddc)
  • Recreating the missing folder and manually copying the offending file back in (which removes the linker error) and then carefully deleting it again, which makes the warning return on next boot
  • clicking through the tutorial! yay

None of the above worked. What am I missing?

1 Like

Thanks for the suggestions but no, there are no binaries (that I know of). Interestingly enough, I’m getting it in more projects… Most of them, not all, though. The plot thickens.

I don’t see a warning for a newly created project, like a blank template. I don’t see the warnings in my main project either. It’s a tad puzzling :expressionless:

Just updated from 4.20.1 to 4.20.2 hoping it would go away, but no. I can always reinstall the engine, I suppose. The proverbial switching it off and on may just help.

Got it.

In AppData\Local\UnrealEngine there is a Common folder with derived data caches.

Deleting it sorted it out.


Have you tried removing the project binaries? if any exist.

Unreal Engine should update these cache files, this is a common issue.

Not to mention the outrageous size of that folder when having multiple projects…

Solved it for me. Warning showed up after I renamed my animation montages.