Remove tooltip on button text?

I have several buttons on my start menu that have text labels for ‘New Game’, ‘Credits’, ‘Quit’, etc. When I run the game and hover over the button text, the cursor disappears and the tooltip ‘bar’ comes up and allows me to hightlight the text. I want to remove this so it’s just a normal clickable button.

I went to Behaviour > Is Enabled on the textbox and unticked the box, which does remove the tooltip bar. However, it also removes the text colour/styling so the button label turns grey!

How do I get the button to work normally without breaking the font styling? This sounds like it should be very very simple, which is why it’s so annoying! Any help would be really appreciated!


IsEnabled disables the entire widget - that’s why it shows up greyed out. Clear the Tool Tip Text & remove the binding at the bottom (if you have any, that is).

Can you show a screenshot? This sounds a bit like we’re dealing with Editable Text widget.

Perhaps instead of a Text Block you’ve added Editable Text to your button.

There’s no tooltip text or bindings. I only just created the menu and added a background, a few buttons and a textbox for each of them. Then added text and coloured the font. I haven’t done anything else to it yet.

Just have to go back and redo about 50
buttons in all of my projects!

That’s the reason why you’d want to wrap a button in a widget. So you’d need to do it just once :slight_smile:

Ok, I finally realised what the issue was. All this time I’ve been using a text ‘box’ instead of a text ‘block’ based on a mispronounciation in a tutorial I watched ages ago! (facedesk)

At least I have an answer at long last! Just have to go back and redo about 50 buttons in all of my projects!

Yep,worked that out last night! Aarrrrgh!