Remove relative movement/offset added to child actor :: Blueprint

I’m making top down game and I’m having trouble positioning player’s child actor that contains procedural mesh generated at run time. Mesh covers area that should be out of sight for player.

Below is how I spawn child actor and attach it to my player character.

Bez tytułu.png

If I look around with mouse meshe’s edges remain in place - they nicely flow around objects. But when I use WSAD keys mesh seems to move in the same direction player moves and is cutting/clipping through walls.

I’ve been trying to figure out why it’s happening that way for 2 days now and it’s driving me crazy… It seems to have something to do with character movement component but I didn’t found any option that could relate to that. Root movement also doesn’t seem to play any role. Do you guys have any ideas?

I figure it out, the devil was in order of task during single tick (if I am correct). The actor that holds procedural mesh somehow was getting delayed message of player position. In that actor settings I changed tick group in which calucation of the mesh vertices where made:


I would love to hear some one explaining why it works that way.