Remove maximize button from build window 2

Thanks for answering my previous question: “Remove maximize button from build window” …

However I was talking about removing the maximize button from the native window not the slate kind …

I’ve found this:

… but I can find any settings there …

Anyway - Is there a way to disable or remove the native maximize button on build’s window ?

Hello enzyme42,

While the native window is the window you’re looking to edit, slate still owns that window in UE4. Setting this up is part of the construction arguments for SWindow and cannot be changed there after construction. If you need to do it past construction, you can try to get a hold of the HWND in Windows and then change that directly.

Thanks Matthew - I’ve tried that but with no positive results ;(

Can you please post how to access the HWND from C++ in UE4?

Unfortunately, that’s part of the reason I said “try”. I’m not familiar with trying to do that myself.

I’ll try again and post the results here …

were u able to solve the issue ?
i am also stuck into this issue.

Unfortunatelly not yet :frowning:

can u confirm me if this is the behavior you are getting from shipping build on osx:


for my project, anyhow i need to disable switching to window mode. any idea ?

there is a option in project settings to disable maximizing . but still maximize button gets shown and allows user to switch to window mode.
could it be a bug ?

is it possible to achieve / do that using binary version of ue4 downloaded from epic launcher ?

yes however I’m building for windows only not macos x … also I don’t think there’s a way to completely disable windowed mode …

I’m going to check that out - Thanks … wasn’t there when I first posted about this … maybe it’ll work in windows

It works on Windows ! Thanks Epic ! :slight_smile: