Remove Leaves from trees

Hi,

I have a bunch of trees in my game which caused the game to run slower. I am guessing this is mainly because of the leaves of the trees overlapping each other or simply using too much processing power.
I would like to remove the leaves of at least some of the trees, however, I am not able to remove its material slot (there are 4 slots for the tree).

How would I go about doing this?

Thanks

If you click on the drop down for the leaf material you can clear it


But then you still have your leaf cards left, they just don’t have a material anymore and render with the default.

If you are sure you don’t want the leafs it would be best to reimport the trees without the leafs. But there are ways to optimize foliage, so if you are doing this only because it doesn’t run fast enough you should maybe look at some ways to optimize it.

Yeah but it looks horrible like that, with my trees anyway. Sadly I can’t seem to import them without the leafs attached

You might try setting the opacity for the leaves material to be zero. Not sure if that would eliminate overdraw or not, but it’s easy to try.

An easier optimization you can make it to decrease the LOD distance of the trees. That will make a large impact to performance. You can also decrease the texture size significantly and probably not see a visual difference.

If I am correct in guessing that is the MAWI trees, they have very large textures, like 4k and 8k. You can make it more like 512 or 1024 and in most cases it will look perfectly fine. That will also make a significant boost to performance.

Another trick is you can have like half your trees setup with a different spawner and have shadows turned off for them. In a forest nobody will be able to notice.

If you must absolutely remove the actual leaf cards, you can export the static mesh as an fbx, bring it into your 3d DCC, select by material to get the leaf cards, delete them, then reimport into unreal. Everything should work just fine.