Remove Instanced Static Mesh problem (cutting grass system)

Following [this tutorial][1], I can’t seem to remove instance grass using my “armCollider” in my character_BP, only with the Capsule Component.

I checked all the collisions and everything is detected (the grass has an ’ object channel’ named “foliage”, which is set to be overlapped).

[Here is a video showing the problem.][2]

This is the setup:

I also discovered other things:

-If I print the Other Body Index with the CapsuleComponent, the numbers are all different; but with the armCollider it is always -1.

-If I print the ‘return value’ (bool) from the “Remove Instance” node, for the CapsuleComponent it prints “true”; and for the armCollider it prints “false”.

I don’t know whats going on :frowning:

Make sure that “Generate Overlap Events” is enabled for your armComponent.


Jonathan Lambert

It is, that’s how the armCollider is detecting the grass and showing “-1” when I print the Body Index.

Is the cast successful?

Yes it is. I just tried using a ball with physics enabled and it wont work either. -1 on body index.

Try changing the armCollider from an object type of WorldStatic to Pawn or World Dynamic.

I did and it didn’t work. I tested all kinds of collision and all of them does get detected but the instances wont be removed.