Remove from Parent Widget not really removes

It looks easy to reproduce. After removing item prom parent it looks like it is still somewhere in memory. Thats true that is not present on viewport but looks like the reference is still working. The string is always printed and also I’m able to preview ‘removed’ widet in Debug Filter via widget blueprint.

Mayby it is not a bug? If not then when the widget will really be deleted?

Hello JaroMast,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any other blueprints that may be involved with this issue?

Here is an example of what I tried

In this example I press F to remove all versions of a particular widget from the viewport. After the for each loop is complete it then runs a check for any widgets that may have been left over. This results in nothing printing out (due to no widgets remaining)

Yes I’m able to reproduce this in new project.
Yes your method won’t print anything but the problem is somewhere else. After pressing F few times, please open Remove Test Widget and check how many debug object you have.

GetAllWidgetOfClass return nothing after removing widgets from parent, but if you are holding a reference to removed object, its still valid.

I was able to reproduce this issue on our end. I have written up a report ( UE-22560) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Any news on this bug?

Hello Tredigraph,

I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-22560)

Make it a great day

May I ask, why this issue is still NOT fixed yet?