Remove default actors spawned at start of game

After starting new project I have whole bunch of actors spawning after game start:

Surprisingly, I wasn’t able to get rid of them even after changing GameMode Blueprint in later stages of project. I ignored them for long time since they don’t really interfere with rest of game, but still, having them is something untidy for me. How can I change settings to not spawn those actors or spawn only ones I need?

EDIT: Ok, I think my post made some controversy below. I obviously know how to remove actors from project. Which I don’t know is how to remove spawn calls to new actors when I push Play button. I was able to find that GameMode is responsible for spawning some of them:

Still, I wasn’t able to switch CameraActor. I understand that some of those actors are necessary for engine - you need to have some GameMode, PlayerState and some Camera - but how can I switch them?

Just make a new empty level

Select 1st shift select last 1 and press delete xD.
PS: 1st level that you got on create new project is not saved until you save it manualy. So if you create new level the oldest didn’t got a save xD

Okay, but how can I remove those from existing level? :slight_smile: Also if I would want to spawn similar (but different) actors at the start of the level, how to proceed?

YO, HOW DO I REMOVE SPAWNING ACTORS FROM EXISTING LEVEL. WITHOUT DELETING THE LEVEL.

I told you how in the start of last message. In World Outliner SELECT 1st actor PRESS SHIFT and SELECT last actor PRESS botton DELETE on your keyboard

Jesus…

I want those removed because I have other CameraActor, Default Pawn etc. I guess those are created to give player any vision at the beginning - which I appreciate, because I can have my “hello world” level 5 seconds after creating new project - but usually I create custom player actor with it’s own camera.

In your begin play of your controller you could just destroy the default pawn.

The rest are all very important base classes - when you make your game - you are essential inheriting from them and adding your logic. Can you explain why you want these removed?

Because these are so core & critical - I think you’d have to modify the engine to do this (if that’s what you are really wanting?)

you can right click on the camera item and then go delete - if its there before the level starts. typically my player pawns have cameras in them so yea, you dont need the one on the scene

your default pawn, you will probably want to have your new pawn spawn in place - so with your controller you pick your new pawn. for me I had this problem for my main menu, where i didnt want anything to spawn in

I had this issue as well. I think what you are looking for is:

Select Toolbar > Blueprint Dropdown > Project Settings > Select GameMode > None

Having this problem now. Despite having a camera component on my character (for 3rd person view) and two more CameraActors in the level, the engine spawns a new default camera at the origin when the game starts. Unable to find anything that prevents this. Tried Swelllog’s answer but it made no difference at all. Made sure, as far as I could tell, all project/level settings have the correct classes set in their defaults (set to my created classes) and still the default camera appears.

Ch3shireCat, did you find a solution to this? (And if MK studio is still around, you cannot just delete it from the Outliner, because the camera does not exist until game runtime.)

I know I could make a work around that ignores this camera but it is a mystery as to where it is created and it seems like something a game dev should have an option to control somewhere in the editor… what am I missing?

I know this is an old post but I found a much easier solution:

For the default actors generated by the Game Mode

  1. Edit > Project Settings > Select GameMode > None
  2. For the specific map
    World Settings > Selected GameMode > Default Pawn Class > None

For example, I generated the player Pawn manually in Blueprint, but a tiny DefaultPawn was also being auto generated due to the default setting in the GameMode of “DefaultPawn” for the Default Pawn Class parameter. So the player Pawn would occasionally run into the tiny, almost invisible Default Pawn

Your answer is totally meaningless, just run it and you can see it did nothing to the problem.

Everyone is acting like this is the weirdest question, so I assume it’s some sort of newbie misunderstanding because I have this problem too. No matter how empty I make my level, a whole bunch of default things spawn when I press play.

Instead of asking, “How do I…” can I ask how do YOU guys normally set your camera as default when you set up a new project?

It doesn’t let me set “Game Mode” to None, by the way, and I have created an empty level.

[edit]
After much searching I’ve found that there’s no such thing as setting it with a single checkbox like in Unity, you have to write a script.

amazing bro thanks