Remove click requirement from top down

Hello, I’ve used the top-down click to move template and I put in keyboard and gamepad inputs for movement. I got rid of the mouse icon, and when you click you don’t move, HOWEVER, the game still needs me to click the mouse somewhere on the screen before it will accept any other input from my controller or keyboard. If anybody knows where in the blueprints that click requirement is and how to remove/replace it I would very much appreciate that!

Hey, I’m guessing you’ve already tried your project’s input settings? Project Settings → Engine → Input

I think something like “set input mode game only” would do the trick. If you are focusing a widget or something, you have to set the focus to the viewport again.

If you use “input mode game only” you cannot receive input on a widget, so you have to re-set “input mode ui only” or “input mode game and ui”.