Download

Remove 120 fps limit in editor

Hi,

I think you should remove the hard-coded 120 fps cap in the editor. I think this cap makes it much harder to optimize your graphics settings, especially with Oculus Rift coming where you need a much higher base fps. Mobile games also require you to aim for a much higher fps, considering the game will be running on low-end devices.

I know you can use the Standalone Game preview mode, but this loads much slower and you cannot adjust settings on the fly, so it’s not really a viable alternative.

The cap is also confusing and made me waste a couple of hours trying to find the right settings.

There are many other alternatives to cap fps, including r.VSync, t.MaxFPS and Smooth Frame Rate, so I don’t think removing this should be a problem.

Thanks.

I would like it to be normally locked to 60fps…

Perhaps would be the best to give us a bloody selection, that the command “t.maxfps [SELECTION]” every time the editor is launched?

I agree, a setting in Project Settings would be the best.

I’m pretty sick of typing this myself.

You can remove the cap or set a higher limit by using a custom EditorEngine class.



UCLASS(config = Engine, transient)
class HYBRIDMIDDLEWARE_API UMiddlewareEditorEngine : public UUnrealEdEngine
{
   GENERATED_BODY()
   public:

   UMiddlewareEditorEngine()
   {  
      SmoothedFrameRateRange = FFloatRange(5, 240);
   }
}


https://nerivec.github.io/old-ue4-wi…me-module.html

Note that within the editor your FPS is immensly reduced by the UI elements. If you realy want high FPS in editor, make sure you show the least amount of widgets possible. e.g. Details panel of actor is pretty expensive. Overlap widgets you barely use with others (in the same section of the editor, so that a tab bar is created), this helps as only the front widget is rendered.

It’s the enormous amount of power that gets wasted that bothers me, plus the irritating noise my graphics card fans make. I’m looking at around 240W for my graphics card alone in, say, Car Configurator with an uncapped framerate in the editor. I fix it by using a 30FPS fixed frame rate in the project settings and that drops it to around 65W and the fans stop completely on mine. A global editor setting and/or 30/60/uncapped hotkeys would be very useful instead.