Remote iOS build fails with missing dll errors

Hi,

I am following these instructions to set up remote building for iOS from a Windows PC to a MacBook on my local network: https://answers.unrealengine.com/questions/450714/how-to-setup-remote-build.html

I have completed all instructions, but when I press Generate SSH Key the following errors appear:

I assume this is an error with running DeltaCopy’s ssh.exe. Does anyone know how I can solve this issue?
I am running Windows 10.

Thanks.

Epok,

You should not have to add the DeltaCopy link into the engine anymore, if you’re still doing that - since you’re on 4.14 as it’s already included in the engine.

Here are some steps that should cover all of the steps to make sure your SSH has been set up correctly:

  • Verify that Epic Games/4.13/Engine/Extras/ThirdPartyNotUE/DeltaCopy exists.
  • DeltaCopy path exists and contains Binaries, Source, DeltaCopy.tps and DeltaCopy_License.txt
  • In the Editor: select Edit > Project Settings > IOS > Build > Remote Build Options (expand)
  • Enter the Remote Server Name (Computer name or IP of the Mac)
  • Enter the RSync User Name (User name of the Mac)
  • Link the Delta Copy install path (if pre-4.13.0, 4.13.0+ the DeltaCopy field will no longer be necessary)
  • Press the Generate SSH Key button
  • SSH Key generation steps:
  • Press any key to continue…
  • Enter remote workstation’s password
  • Enter Passphrase (usually blank)
  • Enter Passphrase again
  • Press any key to continue…
  • Enter remote workstation’s password
  • Press any key to continue…
  • Close Console

Great, working now. Thank you!

You’re welcome. :smiley: