Remote IOS Build error using Rsync

Remote Builder complete compile. and builder return to error message.

“no such file or directory: ‘@/Users/uebuild/UE4/Builds/CASSU-CLIENT/E/Unreal Projects/SunTemple/Intermediate/Build/IOS/LinkFileList_SunTemple-IOS-Shipping.tmp’”

But Mac have that file. and File Permissions is everyone no Access.

I using Xcode 6.4 and OSX 10.10 4

[link text][2]

Hi RenaZard,

Can you post a screenshot of your rsync setup in the Editor itself? Thanks!

project Remote setting

Ok, that all looks good. And you’ve got the remote hosting set up on the Mac?

Checkbox should be in the System Preferences>Sharing>Remote Login. The private key for the certificate needs to be in the System Keychain. Everything there looks good?

This is my mac sharing setting.

Ok, what version of the editor are you using? There were some changes in the 4.8 release to the rsync process. Are you using binary or source from Github?

I using Github Source and version is 4.8.2

Ok, so really early on in the log you posted it mentions it couldn’t transfer all of the attributes to the exact file it says is missing later on. Could you go to the remote mac and delete this directory entirely: /Users/uebuild/UE4/Builds

I suspect the permissions are broken from the previous build and forcing it to recreate the directories may fix the problem.


I deleted directory and windows pc build project. Create directory automatic.
But build result is same ㅠㅠ

Hey RenaZard,

I have reached out to our iOS developer for additional assistance. Thank you for your patience. :slight_smile:

Do you have a new log or is it exactly the same as the old log? When you run the remote build, what did you use to create the SSH key and is it the same as the uebuild where the build is being created? Does the uebuild have permissions to create folders and files?


Hi I am having the exact same issue - on the GitHub master branch for me. I am using the same for everything and that is an on my mac.

Seems like some of my errors go away if I do the following:
On my host PC, open a Cygwin console and set permissions on my IOS related folders to 777:

chmod -R 777 /cygdrive/D/UnrealEngine/master/Engine/Intermediate/IOS

chmod -R 777 /cygdrive/D/UnrealEngine/master/Engine/Intermediate/IOS-Deploy/

chmod -R 777 /cygdrive/D/UnrealEngine/master/Engine/Binaries/IOS/

On my Mac, also set permissions to 777:

chmod -R 777 ~/UE4

chmod -R 777 ~/Library/MobileDevice/

I attach today log and my build setting


Generate sshkey

File Attribute

[link text][4] Build Log

Hi GreateGuru.~

Can you use Rsync or RemoteBuildTool?

rsync appears to work fine but, as you experienced too, it seems to think that certain files have no permissions set. On another web site I found this explanation (not sure if this applies but could be the issue):

Your problem stems from the fact that the Unix permissions on that [Windows] directory really are 0. All of the access information is stored in separate ACLs, which rsync does not copy. Thus, it sets the permissions on the remote copy to 0.

(Rsync on Windows: wrong permissions for created directories - Stack Overflow)

Maybe something like --no-perms --no-owner --no-group should be passed to rsync since permissions really don’t matter in this case.

The RemoteBuildTool seems to work for me since I see files being compiled.

Ok here’s another workaround: Give the Everyone “Full control” to the following folders:

  • Engine\Binaries\IOS
  • Engine\Build\IOS
  • Engine\Intermediate\Build\IOS
  • Engine\Intermediate\IOS
  • Engine\Intermediate\IOS-Deploy

If the Everyone is not listed, add it.

Also you might have to clear permissions on already exiting files on your Mac by opening up a terminal window on your Mac and running chmod -R 777 ~/UE4/.