Download

Remote Desktop Issue

Hello all. New to UE4, have it running in remote desktop on my mac pro. Works surprisingly great for the most part. The only issue I’ve had yet is when I hit play and the mouse cursor disappears to control the in game view. When I do this the mac pro mouse cursor appears, as it thinks I switched out of my remote desktop window. The result is controlling both the in game view AND the mac pro mouse cursor. Which would be fine if they tracked 1 to 1, but the mac pro mouse hitting the screen boundaries only translates to a small amount of in game movement. What I mean by that is say when I move the cursor 3 inches, the in-editor game view only moves 1 inch. So you can’t really control anything when playing in the editor. Either way it’s weird because normally clicking outside of a remote desktop window completely transfers control to the mac, but in this case I can see the cursor has changed to the one for the mac (I changed the cursor to make it obvious bc I had a hunch of what was happening) but still can control the character (partially) in the editor on windows…

So a couple of things to mention:

I’ve tried every combination of playing in viewport, windowed, full screen etc… All have the same issue. Have tried multiple remote desktop apps all have the same issue.

When I plug my PC into a monitor it works perfectly.

Hope I explained this well enough. Basically when playing in editor the mac thinks it has control again… Anyone know of anything that might fix this? Thanks for any replies in advance!!