Download

Remote compiling requires a server name

Hi guys

I am trying to package my iOS game but I keep getting the error message “Remote compiling requires a server name” when I hit package.

I do not understand why I am getting this message, the game is not multiplayer, all of is local to the device, no part of the game does anything remotely over a network. I am on 4.15 compiled from source. I did not get this error on 4.14.

I have also made a copy of my game and attempted to package using the regular unreal engine 4.15, same message.

All my provisions, certificates are all valid, matching and set up properly. I have no idea what might be causing this.

My specs:

Windows 10 64bit Professional
All updates and updated drivers installed
Unreal Engine 4.15 Compiled from source

The game cooks content for windows and builds completely with no errors.

Any ideas? And is there any additional information that I can provide that would help?

Thank you in advance. I tried attaching a screen shot but it will not let me.

If you have source code in your project you need to compile this on Mac. You should configure Mac and connect remotely from Windows. Instructions how to do this you can find there: https://docs.unrealengine.com/latest/INT/Platforms/iOS/Windows/

It is ridiculous that this is required. This is likely another stupid requirement made by Apple. I hate Apple so much. This is just a useless unnecessary step that should not be required. I do not blame epic for this. I blame bad Apple policies. Thank you still though.

iOS code must be compiled on Mac (indeed this is Apple policy). Launcher UE4 version has precompiled code so this is the only case when you don’t need Mac.

Look, if you have a good pc, you can compilling to ios also .
Install a Virtual box , add Yosemite (Take some tutorials from Youtube).(a better one if your pc can run very whell both OS )( I have i5 ,16 gb and i run Yosemite )
Then Download Xcode 7.2.1 or 7 .
Add in your xcode your username and download all certiticates and provisions, (in preference)
Copy certificates from Login in System , that you do in Keychan nd be sure do give full acces to everyone to modify it .
then go to Sharing in System Preference,and share Remote Login.
Copy Username and Server name from Remote Login and add to your UE4 from Windows.
Generate a SSH Key.
Thenn copy from Yosemite to Windows, cerficates and provisions .
and then your are able to compile iOS, at long you hold on Yosemite also :).

But you should remember that it’s not legal :wink:

Because it’s violate apple policy ?
So in this case I do not recommend anyone else to do so .

I don’t understand either. I am working in Windows 10 and have compiled to IOS and tested the app on my IPAD a bunch of times and was working fine, then out of nowhere I get the message “Remote compiling requires a server name…” I removed saved & intermediate folders with no luck. The only way I can fix this which I have done about 3 times so far is to migrate to a new project and start again, but then eventually I end right back to the message again. I don’t get it.

Windows support phone number UK +44_800.041.8318
MICROSOFT WINDOWS +44_800.041.8318 UK
Windows customer care number UK +44.800.041.8318
Dell computer support US +1.844.577.2999
Dell computer slow +1_844.577.2999
MICROSOFT office support US +1_844.577.2999