Remote Build Fails: Unable to determine home directory for remote user


I have had a lot of trouble setting up a remote build to my mac. My mac is in the same room as my pc. I have set up the remote settings correctly because I am able to remote into my mac with my PC using the command prompt "ssh deklein@“myipaddress”. Also, I am able to generate an SSH key successfully, make sure permissions are opened up on that key, and have moved the key to the local project folder and told UE4 to look there for the key. No matter what I try, i keep getting this error soon as I enable plugins on my ue4 project that need to be complied on my mac.

Could this be an issue with Delta Copy?

If anyone has any ideas or tricks that I haven’t tried please let me know. Thank you!

Started fresh project → got new provision & certificate → built to ios without plugins but with remote build settings enabled → it worked → I enabled a plugin → Tried to remote build to ios using my mac → Same error "Unable to determine home directory for remote user.

I was able to fix my problem. I am not 100% sure that what I did is why it got fixed. I created a new user on the mac, gave them admin permissions, enabled remote access, and while signed into this new user, change my settings in UE4 from the old username to the new username and it let me build. I have no idea why my initial main account stopped working in the first place because I didn’t touch any settings.