Remote build cygwin permission denied on windows 10

Hey Guys,

I’m trying a remote build from windows to my mac but i’m getting this weird problem.

LogPlayLevel: UnrealBuildTool: Compiling with iPhoneOS SDK 10.3 on Mac 192.168.1.xx
LogPlayLevel: UnrealBuildTool: Warning: Identity file /cygdrive/C/Users/myUser/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/192.168.1.xx/myUser/RemoteToolChainPrivate.key not accessible: No such file or directory.
LogPlayLevel: UnrealBuildTool: Permission denied, please try again.
LogPlayLevel: UnrealBuildTool: Permission denied, please try again.

Whatever i tried on my private file changing didn’t help, i had a lot trouble with the warning “your private key is accessible by others” then i limit my user only to read and added users group with full permission or read and played around no help…

bump!!! need suggestion

bump looking for solution still

Same issue here… Seems like cygwin cannot see windows permissions properly. Strange enough remote builds were working just fine 2 days ago.

long time nothing from epic…

Re-installed Windows 10, installed only the required deps for a clean unreal development environment (VS2015, git, etc) and now it’s working fine, no more “ssh key file permissions issue”.
There seems to have some issue between the Rsync version bundled with the deltacopy bundled with the UnrealEngine and some other thing installed on my system.

Some steps that I tried to troubleshoot the problem (after trying to solve it by fixing all the file permissions mess with NTFS and cygwin) though I never got the remote build working: I tried to manually run the exact same command with the same args that the Unreal Build Tool did with the bundled rsync.exe and got the same errors. Then I ran it again, with the same args with an updated version of rsync.exe (from my cygwin bin dir) and it ran just fine.

no comment, i wont format my pc just for this… epic needs to fix this issue.

Try running the engine directly from its folder as administrator.
I.e . right click \UE_4.18\Engine\Binaries\Win64\UE4Editor-Cmd.exe and select Run as administrator. Then load the project from the engine’s project browser that opens.
You can also go to the exe file properties > Compatibility and check the Run this program as administrator. Then you can launch the project in every way you’d like.

That did the trick for me.

Same, I had to delete all existing SSH keys then recreate them and run UE4 as admin.