Remapping changes visible in dev kit testing, but not in game.

And yes, the mod is loading :wink:

It’s a little complex, but bear with me:

  • The mod is a TC.
  • The remapping is in the mod folder, not the game folders like the TC sections of the mod
  • Other aspects of the mod folder are working, such as a new engram/item (though strangely, only on a ‘copied’ map that seems to be part of the TC and is identical to the island, though I don’t remember adding a map to the mod. But that’s another issue, and one I can work around for now…)
  • I have copied the remapped item (cloth armour, all 5 pieces) to the mod folder, and used the remapping function in primalgamedata to point from the original game files, and to the new files.
  • This works when I run the game in the devkit, but not when I launch in single player (either on the TC’s copied map - which seems to have inherited the mod name - or on the original ark map)

As for how I set up the mod:

  • Testgamemode is referenced in primalgamedata, primalgamedata and testgamemode are both referenced in the override functions in the world settings of the orange level file of the mod.
  • When I cooked, I cooked as a TC.
  • For now, the level file is also forceloading ‘TheIsland’ as a map as for some reason when I tried removing it (to allow it to be used with other maps), the ‘copied’ map (see above) was black and utterly empty. I’m assuming that’s why it looks like the island, it’s forceloading the island.

Still not sure why it’s uploaded as a second map though, or why ANY (including the engrams) mod files wont work on the original ark map.