Download

Release Branch Build Fails (Slimmed Down Build)

I’m working from the current Release branch, and have made a few minor modifications to the setup.bat to reduce the file download size. Unfortuantely, my engine build is now failing due to some issues created by iPhonePackager. I suspect this is a dependency issue.

I ran Setup.Bat with the following command line params. I only care about Windows, PS4 and Xbox One Platforms and use VS2015 - so there’s no need for this other stuff.



D:\GIT\UnrealEngine\Setup.bat -exclude=Linux -exclude=IOS -exclude=Android -exclude=HTML5 -exclude=VS2012 -exclude=VS2013 -exclude=Mac -exclude=Dingo


I also deleted the ‘Samples’ and ‘Templates’ folders, and added a .gitdepsignore file with the following entries. This just means that setup.bat won’t download files for the following folders (other than Engine/Extras/Redist)



/Engine/Documentation/**
/Engine/Extras/**
/FeaturePacks/**
/Samples/**
/Templates/**
!/Engine/Extras/Redist/**


It worked, I have a much smaller source repo on my drive now - but when trying to build, I get the following errors:

Errors.PNG

So, something doesn’t work with this configuration even though I feel like it should. BouncyCastle.crypto is missing according to Solution Explorer - but that’s not up to me to find it right?

Alright so first find is that using -exclude=VS2012 causes the problem with “silk_common.lib” missing.

This is because it only exists here. Suggest this is fixed or repaired for a future engine build:



'ThirdParty/libOpus/opus-1.1/win32/VS2012/x64/Release/\silk_common.lib'


Source

Second find, also related to excluding VS support. Excluding VS2013 causes the problem with coremod.lib for the UE4Editor-SoundModImporter.dll file

Again, suggesting this as a fix for a future engine build:



C:\Program Files\Epic Games\UE_4.15\Engine\Source\ThirdParty\coremod\coremod-4.2.6\lib\Win64\VS2013\coremod.lib


Now trying to package a Launcher (Rocket) build fails due to the missing iPhonePackager files.

What’s the workaround for this?

Alright, after two days of trying to eliminate platforms from a source build and many hours wasted for UAT to build the engine - I give up.

Running setup.bat to reduce dependency downloads just plain doesn’t work, because the system is far too basic. All it does is reject folder contents based on folder names so it seems, so you end up missing loads of files - and many of those files are referenced all over the engine.

This is one of those features that feels like it’s been added without actually being tested properly. It’s a shame you can’t completely nuke support for certain platforms in source builds :confused: Now I have an unnecessarily large engine build to distribute around…